summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-22 08:52:37 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-22 08:55:04 +0100
commitd7850a8c5e5797a78726d4d8bfda8d69bf17f36a (patch)
tree542473fd4e19d7f102fcad517ef7be634834ae0a /dev-python/tabulate
parentsys-cluster/kube-scheduler: 1.19.8 bump (diff)
downloadgentoo-d7850a8c5e5797a78726d4d8bfda8d69bf17f36a.tar.gz
gentoo-d7850a8c5e5797a78726d4d8bfda8d69bf17f36a.tar.bz2
gentoo-d7850a8c5e5797a78726d4d8bfda8d69bf17f36a.zip
dev-python/tabulate: Bump to 0.8.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tabulate')
-rw-r--r--dev-python/tabulate/Manifest1
-rw-r--r--dev-python/tabulate/tabulate-0.8.9.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/tabulate/Manifest b/dev-python/tabulate/Manifest
index d143606a83ee..3b610a0da231 100644
--- a/dev-python/tabulate/Manifest
+++ b/dev-python/tabulate/Manifest
@@ -1 +1,2 @@
DIST tabulate-0.8.7.tar.gz 40800 BLAKE2B 4e15ef79d152ed6a01fcc88496aed81462e2ac5c5aea1a9977eca955d3c6d743019f8c56a48ef268217cdd7c2780505c4837020ff8cb1bda442304d82e560a5c SHA512 77eb619d3115bbd574ff72b82d55e09f1e2bfe29da0b937b72930b3e65423135722bdc54bed818adf2e25cb49a58f8f85d0ca3b3ed0fcfcfda34a25e54781d0c
+DIST tabulate-0.8.9.tar.gz 42562 BLAKE2B 6e6e1017379d07d5ede0cdfb6a8e3142f60656fd5d5b409c1259239e62637824c3bab0bb0f6b03f8733a24e9e3ac074a80a56d44939a8c6eeab8e9a830ae8277 SHA512 68a4d194068f692b57b2cca0fa42a58ba571b46adaef7f8b1a8cea7e34c78ea0a1c523286c3f1df631897cc60ad39ef6b11bfee61d46c04e2de1fb9ec0b497dd
diff --git a/dev-python/tabulate/tabulate-0.8.9.ebuild b/dev-python/tabulate/tabulate-0.8.9.ebuild
new file mode 100644
index 000000000000..c71572c40741
--- /dev/null
+++ b/dev-python/tabulate/tabulate-0.8.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pretty-print tabular data"
+HOMEPAGE="https://pypi.org/project/tabulate/ https://github.com/astanin/python-tabulate"
+SRC_URI="https://github.com/astanin/python-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/python-${P}"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep 'sqlite')
+ dev-python/colorclass[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' 'python3*')
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/tabulate-0.8.6-avoid-pandas-dep.patch"
+)
+
+distutils_enable_tests pytest