summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-09-27 11:07:27 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-09-27 12:17:19 +0200
commit35a997d925276b782c656d5d59d40377078acfc7 (patch)
tree0e7e98e1565dbfd100da5e602f91e13b1a1b7b03 /dev-python/tempora
parentnet-p2p/airdcpp-webclient: remove old. (diff)
downloadgentoo-35a997d925276b782c656d5d59d40377078acfc7.tar.gz
gentoo-35a997d925276b782c656d5d59d40377078acfc7.tar.bz2
gentoo-35a997d925276b782c656d5d59d40377078acfc7.zip
dev-python/tempora: bump to 1.6.1, add doc.
Package-Manager: portage-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/2419 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/tempora')
-rw-r--r--dev-python/tempora/Manifest1
-rw-r--r--dev-python/tempora/metadata.xml5
-rw-r--r--dev-python/tempora/tempora-1.6.1.ebuild53
3 files changed, 57 insertions, 2 deletions
diff --git a/dev-python/tempora/Manifest b/dev-python/tempora/Manifest
index 7c45e1f6b53f..1a6ab1365e49 100644
--- a/dev-python/tempora/Manifest
+++ b/dev-python/tempora/Manifest
@@ -1 +1,2 @@
DIST tempora-1.4.tar.gz 7173 SHA256 ea5b4f8774408f2c7fe018fd04dae61d4910f032c8124b0b851f962884b65b7b SHA512 8ba86ec90ec3ade059ad683ff26586b4d32ded7aaa5031ef90c735393d183902015d63607f382fd950ef7d4bd8b4f9256aff6b70d20f57f6bbbc947a1dece365 WHIRLPOOL 2c185af421483bdb17736b3023c3c32014803f167ce5fa85b0634210b3c20143ee0f89e338dca33ba0976264b6f0d27d6dad92874a6f6ed1d97cb68672afed6c
+DIST tempora-1.6.1.tar.gz 11423 SHA256 1c15b3ec37933192470e7e7f0dcd5fbb372a85f13c86ddb4c306f280a7fc1453 SHA512 9baf9162e304e59ae0a427a7a27d1fc66b0d4b98e016490317832ba2e7acec520ef2baeebeb26f7984ba7ace82413d15b96baef7dbdfcfdc94e29e7179769a01 WHIRLPOOL 25be89baeb5976157bfe259c97339461b18528e357d1476a3d614b9526325785942baa940e9d29b4df3b9ba46bd9a03a56e23314285da70ed2743e20f68561e4
diff --git a/dev-python/tempora/metadata.xml b/dev-python/tempora/metadata.xml
index 1368bce3f9d0..1d4744427d59 100644
--- a/dev-python/tempora/metadata.xml
+++ b/dev-python/tempora/metadata.xml
@@ -4,7 +4,6 @@
<maintainer type="person">
<email>sautier.louis@gmail.com</email>
<name>Louis Sautier</name>
- <description>Proxied maintainer; set to assignee in all bugs</description>
</maintainer>
<maintainer type="project">
<email>proxy-maint@gentoo.org</email>
@@ -12,6 +11,8 @@
</maintainer>
<upstream>
<remote-id type="pypi">tempora</remote-id>
- <remote-id type="bitbucket">jaraco/tempora</remote-id>
+ <remote-id type="github">jaraco/tempora</remote-id>
+ <bugs-to>https://github.com/jaraco/tempora/issues</bugs-to>
+ <changelog>https://github.com/jaraco/tempora/blob/master/CHANGES.rst</changelog>
</upstream>
</pkgmetadata>
diff --git a/dev-python/tempora/tempora-1.6.1.ebuild b/dev-python/tempora/tempora-1.6.1.ebuild
new file mode 100644
index 000000000000..b602e5964b91
--- /dev/null
+++ b/dev-python/tempora/tempora-1.6.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Objects and routines pertaining to date and time"
+HOMEPAGE="https://github.com/jaraco/tempora"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+# The calc-prorate binary used to be part of jaraco.utils
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ !<=dev-python/jaraco-utils-10.0.2
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/rst-linker[${PYTHON_USEDEP}]
+ )
+ test? (
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}