summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-09-17 17:58:32 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-09-22 15:56:08 +0200
commit57c82a2809c4f2a0724a6c6853119cd36090b17a (patch)
treedf075a7262809dfd9f07adc419f02470a2bef851 /dev-python/tempora
parentnet-im/slack-bin: version bump to 2.8.0 and add new dependencies. (diff)
downloadgentoo-57c82a2809c4f2a0724a6c6853119cd36090b17a.tar.gz
gentoo-57c82a2809c4f2a0724a6c6853119cd36090b17a.tar.bz2
gentoo-57c82a2809c4f2a0724a6c6853119cd36090b17a.zip
dev-python/tempora: version bump to 1.9.
Package-Manager: Portage-2.3.8, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/5715
Diffstat (limited to 'dev-python/tempora')
-rw-r--r--dev-python/tempora/Manifest1
-rw-r--r--dev-python/tempora/tempora-1.9.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/tempora/Manifest b/dev-python/tempora/Manifest
index 228c926565e5..c8d0499a59c7 100644
--- a/dev-python/tempora/Manifest
+++ b/dev-python/tempora/Manifest
@@ -1,2 +1,3 @@
DIST tempora-1.6.1.tar.gz 11423 SHA256 1c15b3ec37933192470e7e7f0dcd5fbb372a85f13c86ddb4c306f280a7fc1453 SHA512 9baf9162e304e59ae0a427a7a27d1fc66b0d4b98e016490317832ba2e7acec520ef2baeebeb26f7984ba7ace82413d15b96baef7dbdfcfdc94e29e7179769a01 WHIRLPOOL 25be89baeb5976157bfe259c97339461b18528e357d1476a3d614b9526325785942baa940e9d29b4df3b9ba46bd9a03a56e23314285da70ed2743e20f68561e4
DIST tempora-1.7.tar.gz 11645 SHA256 a264672b7f39198eb90b531490ade4e873f6e13839253636c3bd6a5549be1984 SHA512 2420e32a9b8c990609d8f09225004e0b1c445cad1fe3c3c74625cb8317b552469acf2d3b28aa56633a87260a93c77d73b02178cb662016c514bc740aa01399e5 WHIRLPOOL ecb7df3e1af35a60f7c060203cad463f610468752b0d9a0f27992a0a75fae8c05c57875dfed797d3db94cd7d937a2d3d2291f0607ff0adb619012353bcabb941
+DIST tempora-1.9.tar.gz 12469 SHA256 9ea980c63be54f83d2a466fccc6eeef96a409f74c5034764fb328b0d43247e96 SHA512 cb049675d7196738debca3dc0ddd8c5e72d0468bd1a853f77378cc5564b100cd94d23c63d7b06c6bed2827365d904a1582cf9d497618493b795600b6d476b91f WHIRLPOOL 8e74390bb88c1a7ec091a60ea87613aa26c4dcb1de1cb8139aa9818fc6d41cff99512990ee6200d54014b80bb597bab40c880648646af1d503ae2ae85d2e1a3a
diff --git a/dev-python/tempora/tempora-1.9.ebuild b/dev-python/tempora/tempora-1.9.ebuild
new file mode 100644
index 000000000000..ac0b0ba352ad
--- /dev/null
+++ b/dev-python/tempora/tempora-1.9.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Objects and routines pertaining to date and time"
+HOMEPAGE="https://github.com/jaraco/tempora"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+# The calc-prorate binary used to be part of jaraco.utils
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ !<=dev-python/jaraco-utils-10.0.2
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/rst-linker-1.9[${PYTHON_USEDEP}]
+ )
+ test? (
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}