summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-06-10 17:16:01 +0200
committerMichael Palimaka <kensington@gentoo.org>2017-06-11 17:02:26 +1000
commitec0afcc75a8974ffd9ead440739e3499c633e7df (patch)
tree703924740dc5889e290e75e580b27dee7b5d9c73 /dev-python/tempora
parentdev-perl/Google-Ads-AdWords-Client: Cleanup old re bug #613404 (diff)
downloadgentoo-ec0afcc75a8974ffd9ead440739e3499c633e7df.tar.gz
gentoo-ec0afcc75a8974ffd9ead440739e3499c633e7df.tar.bz2
gentoo-ec0afcc75a8974ffd9ead440739e3499c633e7df.zip
dev-python/tempora: bump to 1.7, add pypy{,3} and py3.6
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/tempora')
-rw-r--r--dev-python/tempora/Manifest1
-rw-r--r--dev-python/tempora/metadata.xml1
-rw-r--r--dev-python/tempora/tempora-1.7.ebuild53
3 files changed, 54 insertions, 1 deletions
diff --git a/dev-python/tempora/Manifest b/dev-python/tempora/Manifest
index 1a6ab1365e49..050624bbd24e 100644
--- a/dev-python/tempora/Manifest
+++ b/dev-python/tempora/Manifest
@@ -1,2 +1,3 @@
DIST tempora-1.4.tar.gz 7173 SHA256 ea5b4f8774408f2c7fe018fd04dae61d4910f032c8124b0b851f962884b65b7b SHA512 8ba86ec90ec3ade059ad683ff26586b4d32ded7aaa5031ef90c735393d183902015d63607f382fd950ef7d4bd8b4f9256aff6b70d20f57f6bbbc947a1dece365 WHIRLPOOL 2c185af421483bdb17736b3023c3c32014803f167ce5fa85b0634210b3c20143ee0f89e338dca33ba0976264b6f0d27d6dad92874a6f6ed1d97cb68672afed6c
DIST tempora-1.6.1.tar.gz 11423 SHA256 1c15b3ec37933192470e7e7f0dcd5fbb372a85f13c86ddb4c306f280a7fc1453 SHA512 9baf9162e304e59ae0a427a7a27d1fc66b0d4b98e016490317832ba2e7acec520ef2baeebeb26f7984ba7ace82413d15b96baef7dbdfcfdc94e29e7179769a01 WHIRLPOOL 25be89baeb5976157bfe259c97339461b18528e357d1476a3d614b9526325785942baa940e9d29b4df3b9ba46bd9a03a56e23314285da70ed2743e20f68561e4
+DIST tempora-1.7.tar.gz 11645 SHA256 a264672b7f39198eb90b531490ade4e873f6e13839253636c3bd6a5549be1984 SHA512 2420e32a9b8c990609d8f09225004e0b1c445cad1fe3c3c74625cb8317b552469acf2d3b28aa56633a87260a93c77d73b02178cb662016c514bc740aa01399e5 WHIRLPOOL ecb7df3e1af35a60f7c060203cad463f610468752b0d9a0f27992a0a75fae8c05c57875dfed797d3db94cd7d937a2d3d2291f0607ff0adb619012353bcabb941
diff --git a/dev-python/tempora/metadata.xml b/dev-python/tempora/metadata.xml
index 364c35c637e3..acfe243c28e6 100644
--- a/dev-python/tempora/metadata.xml
+++ b/dev-python/tempora/metadata.xml
@@ -14,6 +14,5 @@
<remote-id type="github">jaraco/tempora</remote-id>
<bugs-to>https://github.com/jaraco/tempora/issues</bugs-to>
<changelog>https://github.com/jaraco/tempora/blob/master/CHANGES.rst</changelog>
- <remote-id type="bitbucket">jaraco/tempora</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/tempora/tempora-1.7.ebuild b/dev-python/tempora/tempora-1.7.ebuild
new file mode 100644
index 000000000000..ac0b0ba352ad
--- /dev/null
+++ b/dev-python/tempora/tempora-1.7.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Objects and routines pertaining to date and time"
+HOMEPAGE="https://github.com/jaraco/tempora"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+# The calc-prorate binary used to be part of jaraco.utils
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ !<=dev-python/jaraco-utils-10.0.2
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/rst-linker-1.9[${PYTHON_USEDEP}]
+ )
+ test? (
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}