summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-08-26 22:44:35 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-08-26 23:25:08 -0500
commitb1539aa6ae38b58097d2bd4db8f25d2ad3f7abb7 (patch)
treed1d12b6e97d6395a0fe030a6f4016d2abc49bf3b /dev-python/tenacity
parentdev-python/kombu: 4.1.0 bup (diff)
downloadgentoo-b1539aa6ae38b58097d2bd4db8f25d2ad3f7abb7.tar.gz
gentoo-b1539aa6ae38b58097d2bd4db8f25d2ad3f7abb7.tar.bz2
gentoo-b1539aa6ae38b58097d2bd4db8f25d2ad3f7abb7.zip
dev-python/tenacity: 4.4.0 bup
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/tenacity')
-rw-r--r--dev-python/tenacity/Manifest1
-rw-r--r--dev-python/tenacity/tenacity-4.4.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/tenacity/Manifest b/dev-python/tenacity/Manifest
index 98a7b9b478a9..df84d606a28f 100644
--- a/dev-python/tenacity/Manifest
+++ b/dev-python/tenacity/Manifest
@@ -1 +1,2 @@
DIST tenacity-3.7.1.tar.gz 22915 SHA256 86cae49f4334277164b97a1871828e9173d669b9bb223de44ba8c1cee787bbfa SHA512 83f277da3ee7beca4d564610a4ef46c33a87590214a41c0c36c9bb46920e5e8e7e8a8d130dcaac2802d058f7e995fbe01e13d5b7a65821e9a1e83072b78e3f00 WHIRLPOOL c8747efea73d5fd966cd448dc3b2d33341f0ed2a53287df2fe98b0a587522b984461be07159e5b0817b60650e3cfafb0a6e673d1dcd96b7c138782728c75df63
+DIST tenacity-4.4.0.tar.gz 26133 SHA256 9c5554b494dd8bae998dbffd7b8d1876e6b94de0c1df1ac51d0db25bb9f830b2 SHA512 08f4eef91e38f8d166029625e337057bd9a934fd58473d8c3666436e6312a0f7dd7f24dea05c8427df627bd37c7003602089970079f214fa7b79beee64df3f96 WHIRLPOOL f12433c89c0a4b2139be4d74dfb3812dcde9dae7feec9517d9287f85313fbe86567a1b9f9c3f55c1b4b864a84eaaac5097cc440dbffdb01a6425c0ef647b259d
diff --git a/dev-python/tenacity/tenacity-4.4.0.ebuild b/dev-python/tenacity/tenacity-4.4.0.ebuild
new file mode 100644
index 000000000000..9fbf25820eb8
--- /dev/null
+++ b/dev-python/tenacity/tenacity-4.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="General-purpose retrying library"
+HOMEPAGE="https://github.com/rholder/retrying"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ >=dev-python/monotonic-0.6[${PYTHON_USEDEP}]
+"