summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2020-03-02 22:15:43 +0700
committerAndrey Grozin <grozin@gentoo.org>2020-03-02 22:15:43 +0700
commitb477a56dac3e941e967a6e8dc336968afe47ae2b (patch)
tree3993cd57540671a7763deb1695a130a75a400920 /dev-python/terminado
parentwww-servers/tornado: bump to 6.0.3; python3_8 added to 5.1-r1 (diff)
downloadgentoo-b477a56dac3e941e967a6e8dc336968afe47ae2b.tar.gz
gentoo-b477a56dac3e941e967a6e8dc336968afe47ae2b.tar.bz2
gentoo-b477a56dac3e941e967a6e8dc336968afe47ae2b.zip
dev-python/terminado: bump to 0.8.3
Package-Manager: Portage-2.3.91, Repoman-2.3.20 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-python/terminado')
-rw-r--r--dev-python/terminado/Manifest1
-rw-r--r--dev-python/terminado/terminado-0.8.3.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/terminado/Manifest b/dev-python/terminado/Manifest
index b17016924e8e..007a980b9181 100644
--- a/dev-python/terminado/Manifest
+++ b/dev-python/terminado/Manifest
@@ -1,3 +1,4 @@
DIST terminado-0.5.tar.gz 10491 BLAKE2B 8beb4784c13ceeea47966efbf56e62b259adac533d2ff72f287984aa100837d8123be3109761c9c282fc081e26d0d26224a8d1bab6263d3abed00839cc576c9b SHA512 8c53e2c8fa837c171a8790744770f41d4fc8fe15fe8abd28af17317950c615e4c75c22ab896fd98984fd9c2bbbc7798e5ffe319827d84eb77889bca63660e421
DIST terminado-0.6.tar.gz 10334 BLAKE2B 02ae2135da982cfe12ea0b3219a67a6b327bd3f4f45539f79629cb33ec0882586094b7084e4ca64567f55fbe6f0194a10934c558fd836f825ef81319920caf5f SHA512 9b9521917d4000aa45e61a1b88705e715f11686890671607cca81d4518f1e17feefdc2ad3de64dd0e053a6849956efbbd838c7b98d570dcc98a936c0a4cfce9c
DIST terminado-0.8.1.tar.gz 21134 BLAKE2B 504fd13ab5efde77b38fbd79e4bbe4b08fb9bc1cf0f4aa8ca6cd90b4dbd20083088d6cc287f78ca159bf5f72a371c146dc0c648e310a0c892f283f2d9fd23199 SHA512 5cf5259954339d567c41b8ef3b4d77de4f69fe41fd371e63775c9d8d5870ee801795462654f16978f4c86e381fcd26437e307458db9ee4e575d31d5377f2a749
+DIST terminado-0.8.3.tar.gz 21165 BLAKE2B ec031cb7828840a4f299aa25de0030d5b7993119fd41b71e698dd032f4fd31ea725a9b610dc53a71d480ee74b49a1d072d76555b434da4f5fee2479efa03fdec SHA512 441355cdc919b6f04b1bf1eb870f24e0bd6c7ef412e72e1747707049b1fa0d6676644e3646007f2653b3df00e1f30048d9dc40d73f0827b2bbfc0821549e140b
diff --git a/dev-python/terminado/terminado-0.8.3.ebuild b/dev-python/terminado/terminado-0.8.3.ebuild
new file mode 100644
index 000000000000..ebcd692b13af
--- /dev/null
+++ b/dev-python/terminado/terminado-0.8.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Terminals served to term.js using Tornado websockets"
+HOMEPAGE="https://pypi.org/project/terminado/ https://github.com/jupyter/terminado"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/ptyprocess[${PYTHON_USEDEP}]
+ >=www-servers/tornado-0.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test -v || die
+}