summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-31 16:05:45 +0200
committerMichał Górny <mgorny@gentoo.org>2022-03-31 16:05:45 +0200
commit606434ea25ad672da0122711f76e42d620236c85 (patch)
tree13bf311c3f437d77e4d2689b7c598d554473da0f /dev-python/testfixtures
parentdev-python/twython: Remove old (diff)
downloadgentoo-606434ea25ad672da0122711f76e42d620236c85.tar.gz
gentoo-606434ea25ad672da0122711f76e42d620236c85.tar.bz2
gentoo-606434ea25ad672da0122711f76e42d620236c85.zip
dev-python/testfixtures: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/testfixtures')
-rw-r--r--dev-python/testfixtures/Manifest2
-rw-r--r--dev-python/testfixtures/files/testfixtures-6.18.1-py3.10.patch172
-rw-r--r--dev-python/testfixtures/testfixtures-6.18.3.ebuild46
-rw-r--r--dev-python/testfixtures/testfixtures-6.18.4.ebuild51
4 files changed, 0 insertions, 271 deletions
diff --git a/dev-python/testfixtures/Manifest b/dev-python/testfixtures/Manifest
index d69d9f63bf71..fb77740e695d 100644
--- a/dev-python/testfixtures/Manifest
+++ b/dev-python/testfixtures/Manifest
@@ -1,3 +1 @@
-DIST testfixtures-6.18.3.tar.gz 122142 BLAKE2B 014cc2245d5fbe0d39310c8e2c21cd5f289d6ec7a6a561d055e86d4cd25b79f1aa535067746219e2382df2aeec050dfa24cdae674636d92ee61016fa9861e705 SHA512 e556e7cb28f122526ef19550b1e593b61f01923d0be53951344f917f89b3d4cae29e525ceda3d0290bc18c3641b509dd7236e7b55ae50da0157fe11ca9f04cca
-DIST testfixtures-6.18.4.tar.gz 124910 BLAKE2B 8c19672903d3b6ba5139b95f1d060c0d71ae8891e8c190a8891fded6d79af3549a91809b73a114f69cf2b0de49740e49a9e38e44981addcd09d7b4c343ea3ced SHA512 2643ddfd7c4be7b514070e2df8e52479ad51f50a8b69507faf36d90bd92aa0201f1c3033eb00e644bac194601b0a9190c02727f18d899629ab09abfa3546ecd7
DIST testfixtures-6.18.5.tar.gz 124944 BLAKE2B 6f1431b3e7201a3c12bf683cfcb123329b186f42a64fdfe3ee7897ab0c5e9ba3995deb88934ae59f0d35b64710ac04b421d07f1c496429b18a0b6a03e600885d SHA512 4d4ec7295bb056102995dc1c872b86059109b114ab921769d3aa2c2de96a3789fef30558f51826655b6d2d668ea1b1bc9f161a4584aab628f59d4da1fa95940e
diff --git a/dev-python/testfixtures/files/testfixtures-6.18.1-py3.10.patch b/dev-python/testfixtures/files/testfixtures-6.18.1-py3.10.patch
deleted file mode 100644
index cd1ecbd8133d..000000000000
--- a/dev-python/testfixtures/files/testfixtures-6.18.1-py3.10.patch
+++ /dev/null
@@ -1,172 +0,0 @@
-From 8fb2122eea0f1d0de1ccca7a3a0f5426bc6d4964 Mon Sep 17 00:00:00 2001
-From: Louis Sautier <sautier.louis@gmail.com>
-Date: Sat, 21 Aug 2021 03:00:51 +0200
-Subject: [PATCH] tests: fix with Python 3.10 (changed exception messages)
-
----
- testfixtures/compat.py | 1 +
- testfixtures/tests/test_popen.py | 41 ++++++++++++++++++------------
- testfixtures/tests/test_replace.py | 24 ++++++++++-------
- 3 files changed, 41 insertions(+), 25 deletions(-)
-
-diff --git a/testfixtures/compat.py b/testfixtures/compat.py
-index 1042d27..ca00f32 100644
---- a/testfixtures/compat.py
-+++ b/testfixtures/compat.py
-@@ -5,6 +5,7 @@
-
- PY_36_PLUS = PY_VERSION >= (3, 6)
- PY_37_PLUS = PY_VERSION >= (3, 7)
-+PY_310_PLUS = PY_VERSION >= (3, 10)
-
-
- if PY_VERSION > (3, 0):
-diff --git a/testfixtures/tests/test_popen.py b/testfixtures/tests/test_popen.py
-index aa211da..4ec3186 100644
---- a/testfixtures/tests/test_popen.py
-+++ b/testfixtures/tests/test_popen.py
-@@ -6,7 +6,7 @@
- from testfixtures import ShouldRaise, compare, Replacer
-
- from testfixtures.popen import MockPopen, PopenBehaviour
--from testfixtures.compat import BytesLiteral, PY2
-+from testfixtures.compat import BytesLiteral, PY2, PY_310_PLUS
-
- import signal
-
-@@ -471,10 +471,11 @@ def test_default_command_max_args(self):
- ], Popen.mock.method_calls)
-
- def test_invalid_parameters(self):
-+ message = "__init__() got an unexpected keyword argument 'foo'"
-+ if PY_310_PLUS:
-+ message = "MockPopenInstance." + message
- Popen = MockPopen()
-- with ShouldRaise(TypeError(
-- "__init__() got an unexpected keyword argument 'foo'"
-- )):
-+ with ShouldRaise(TypeError(message)):
- Popen(foo='bar')
-
- def test_invalid_method_or_attr(self):
-@@ -492,39 +493,43 @@ def test_invalid_attribute(self):
- process.foo
-
- def test_invalid_communicate_call(self):
-+ message = "communicate() got an unexpected keyword argument 'foo'"
-+ if PY_310_PLUS:
-+ message = "MockPopenInstance." + message
- Popen = MockPopen()
- Popen.set_command('bar')
- process = Popen('bar')
-- with ShouldRaise(TypeError(
-- "communicate() got an unexpected keyword argument 'foo'"
-- )):
-+ with ShouldRaise(TypeError(message)):
- process.communicate(foo='bar')
-
- def test_invalid_wait_call(self):
-+ message = "wait() got an unexpected keyword argument 'foo'"
-+ if PY_310_PLUS:
-+ message = "MockPopenInstance." + message
- Popen = MockPopen()
- Popen.set_command('bar')
- process = Popen('bar')
-- with ShouldRaise(TypeError(
-- "wait() got an unexpected keyword argument 'foo'"
-- )):
-+ with ShouldRaise(TypeError(message)):
- process.wait(foo='bar')
-
- def test_invalid_send_signal(self):
-+ message = "send_signal() got an unexpected keyword argument 'foo'"
-+ if PY_310_PLUS:
-+ message = "MockPopenInstance." + message
- Popen = MockPopen()
- Popen.set_command('bar')
- process = Popen('bar')
-- with ShouldRaise(TypeError(
-- "send_signal() got an unexpected keyword argument 'foo'"
-- )):
-+ with ShouldRaise(TypeError(message)):
- process.send_signal(foo='bar')
-
- def test_invalid_terminate(self):
-+ message = "terminate() got an unexpected keyword argument 'foo'"
-+ if PY_310_PLUS:
-+ message = "MockPopenInstance." + message
- Popen = MockPopen()
- Popen.set_command('bar')
- process = Popen('bar')
-- with ShouldRaise(TypeError(
-- "terminate() got an unexpected keyword argument 'foo'"
-- )):
-+ with ShouldRaise(TypeError(message)):
- process.terminate(foo='bar')
-
- def test_invalid_kill(self):
-@@ -535,6 +540,8 @@ def test_invalid_kill(self):
- text = 'kill() takes exactly 1 argument (2 given)'
- else:
- text = 'kill() takes 1 positional argument but 2 were given'
-+ if PY_310_PLUS:
-+ text = "MockPopenInstance." + text
- with ShouldRaise(TypeError(text)):
- process.kill('moo')
-
-@@ -546,6 +553,8 @@ def test_invalid_poll(self):
- text = 'poll() takes exactly 1 argument (2 given)'
- else:
- text = 'poll() takes 1 positional argument but 2 were given'
-+ if PY_310_PLUS:
-+ text = "MockPopenInstance." + text
- with ShouldRaise(TypeError(text)):
- process.poll('moo')
-
-diff --git a/testfixtures/tests/test_replace.py b/testfixtures/tests/test_replace.py
-index 5a77e23..d3544a8 100644
---- a/testfixtures/tests/test_replace.py
-+++ b/testfixtures/tests/test_replace.py
-@@ -13,7 +13,7 @@
-
- from testfixtures.tests import sample1
- from testfixtures.tests import sample2
--from ..compat import PY3
-+from ..compat import PY3, PY_310_PLUS
-
- from warnings import catch_warnings
-
-@@ -259,19 +259,25 @@ def test_something(obj):
- self.failIf(hasattr(sample1, 'foo'))
-
- def test_replace_delattr_cant_remove(self):
-+ if PY_310_PLUS:
-+ message = "cannot set 'today' attribute of " \
-+ "immutable type 'datetime.datetime'"
-+ else:
-+ message = "can't set attributes of " \
-+ "built-in/extension type 'datetime.datetime'"
- with Replacer() as r:
-- with ShouldRaise(TypeError(
-- "can't set attributes of "
-- "built-in/extension type 'datetime.datetime'"
-- )):
-+ with ShouldRaise(TypeError(message)):
- r.replace('datetime.datetime.today', not_there)
-
- def test_replace_delattr_cant_remove_not_strict(self):
-+ if PY_310_PLUS:
-+ message = "cannot set 'today' attribute of " \
-+ "immutable type 'datetime.datetime'"
-+ else:
-+ message = "can't set attributes of " \
-+ "built-in/extension type 'datetime.datetime'"
- with Replacer() as r:
-- with ShouldRaise(TypeError(
-- "can't set attributes of "
-- "built-in/extension type 'datetime.datetime'"
-- )):
-+ with ShouldRaise(TypeError(message)):
- r.replace('datetime.datetime.today', not_there, strict=False)
-
- def test_replace_dict_remove_key(self):
diff --git a/dev-python/testfixtures/testfixtures-6.18.3.ebuild b/dev-python/testfixtures/testfixtures-6.18.3.ebuild
deleted file mode 100644
index 46c5fddf9f53..000000000000
--- a/dev-python/testfixtures/testfixtures-6.18.3.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
-HOMEPAGE="https://pypi.org/project/testfixtures/ https://github.com/Simplistix/testfixtures"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="amd64 ~arm arm64 ~riscv x86 ~amd64-linux ~x86-linux"
-
-BDEPEND="
- test? (
- $(python_gen_impl_dep sqlite)
- dev-python/django[${PYTHON_USEDEP}]
- dev-python/pytest-django[${PYTHON_USEDEP}]
- dev-python/sybil[${PYTHON_USEDEP}]
- >=dev-python/twisted-18[${PYTHON_USEDEP}]
- dev-python/zope-component[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-PATCHES=(
- # https://github.com/Simplistix/testfixtures/commit/8fb2122eea0f1d0de1ccca7a3a0f5426bc6d4964
- "${FILESDIR}/testfixtures-6.18.1-py3.10.patch"
-)
-
-python_prepare_all() {
- # kill weird way of declaring build deps
- sed -e '/build=/d' -i setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local -x PYTHONPATH="."
- local -x DJANGO_SETTINGS_MODULE=testfixtures.tests.test_django.settings
- epytest -Wignore::DeprecationWarning
-}
diff --git a/dev-python/testfixtures/testfixtures-6.18.4.ebuild b/dev-python/testfixtures/testfixtures-6.18.4.ebuild
deleted file mode 100644
index 8755772cbbc7..000000000000
--- a/dev-python/testfixtures/testfixtures-6.18.4.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
-HOMEPAGE="https://pypi.org/project/testfixtures/ https://github.com/Simplistix/testfixtures"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
-
-BDEPEND="
- test? (
- $(python_gen_impl_dep sqlite)
- dev-python/django[${PYTHON_USEDEP}]
- dev-python/pytest-django[${PYTHON_USEDEP}]
- dev-python/sybil[${PYTHON_USEDEP}]
- >=dev-python/twisted-18[${PYTHON_USEDEP}]
- dev-python/zope-component[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # kill weird way of declaring build deps
- sed -e '/build=/d' -i setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local -x PYTHONPATH="."
- local -x DJANGO_SETTINGS_MODULE=testfixtures.tests.test_django.settings
-
- local EPYTEST_DESELECT=(
- # TODO
- testfixtures/tests/test_shouldwarn.py::ShouldWarnTests::test_filter_missing
- testfixtures/tests/test_shouldwarn.py::ShouldWarnTests::test_filter_present
- )
-
- epytest
-}