summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-06 22:09:20 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-06 22:09:20 +0300
commit741934844f14c3f7579a33782847d5709a7f867d (patch)
tree4fa8f84577acbd0602bf17f509868956d7be601b /dev-python/testfixtures
parentdev-python/pillow: Stabilize 9.2.0 sparc, #855680 (diff)
downloadgentoo-741934844f14c3f7579a33782847d5709a7f867d.tar.gz
gentoo-741934844f14c3f7579a33782847d5709a7f867d.tar.bz2
gentoo-741934844f14c3f7579a33782847d5709a7f867d.zip
dev-python/testfixtures: add 7.0.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/testfixtures')
-rw-r--r--dev-python/testfixtures/Manifest1
-rw-r--r--dev-python/testfixtures/testfixtures-7.0.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/testfixtures/Manifest b/dev-python/testfixtures/Manifest
index fb77740e695d..f7d183dd620c 100644
--- a/dev-python/testfixtures/Manifest
+++ b/dev-python/testfixtures/Manifest
@@ -1 +1,2 @@
DIST testfixtures-6.18.5.tar.gz 124944 BLAKE2B 6f1431b3e7201a3c12bf683cfcb123329b186f42a64fdfe3ee7897ab0c5e9ba3995deb88934ae59f0d35b64710ac04b421d07f1c496429b18a0b6a03e600885d SHA512 4d4ec7295bb056102995dc1c872b86059109b114ab921769d3aa2c2de96a3789fef30558f51826655b6d2d668ea1b1bc9f161a4584aab628f59d4da1fa95940e
+DIST testfixtures-7.0.0.tar.gz 126163 BLAKE2B e9f31180878e7645a62b93242344c6cd8335067cf8158b03dbfb46b4ab79d57380809a20d6fdc6a6d4b0aca2d22f5d7c18636607a54c70de4bea39e79a9df6b1 SHA512 5fe56e0a654586c266aab5cebcdbf1e6b9988227605395c3198c759759be0fa98ff3c0a1885711ede5ef6d262a60cd19a29dc6e7a90a1f9f8b57df3cb2d9b97b
diff --git a/dev-python/testfixtures/testfixtures-7.0.0.ebuild b/dev-python/testfixtures/testfixtures-7.0.0.ebuild
new file mode 100644
index 000000000000..8d96b3520597
--- /dev/null
+++ b/dev-python/testfixtures/testfixtures-7.0.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
+HOMEPAGE="https://pypi.org/project/testfixtures/
+ https://github.com/Simplistix/testfixtures"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/sybil[${PYTHON_USEDEP}]
+ >=dev-python/twisted-18[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # kill weird way of declaring build deps
+ sed -e '/build=/d' -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTHONPATH="."
+ local -x DJANGO_SETTINGS_MODULE=testfixtures.tests.test_django.settings
+
+ local EPYTEST_DESELECT=(
+ # TODO
+ testfixtures/tests/test_shouldwarn.py::ShouldWarnTests::test_filter_missing
+ testfixtures/tests/test_shouldwarn.py::ShouldWarnTests::test_filter_present
+ )
+
+ epytest
+}