summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-24 10:21:00 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-24 10:23:15 +0100
commitfd33c0507f55b852c9fcd94a61a2591c94fb3166 (patch)
tree3e8d1ab7c5a65b4ebc98f25c53bfa3913b850039 /dev-python/testfixtures
parentdev-python/nose_fixes: Add python3.5 support (diff)
downloadgentoo-fd33c0507f55b852c9fcd94a61a2591c94fb3166.tar.gz
gentoo-fd33c0507f55b852c9fcd94a61a2591c94fb3166.tar.bz2
gentoo-fd33c0507f55b852c9fcd94a61a2591c94fb3166.zip
dev-python/testfixtures: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/testfixtures')
-rw-r--r--dev-python/testfixtures/Manifest1
-rw-r--r--dev-python/testfixtures/testfixtures-4.9.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/testfixtures/Manifest b/dev-python/testfixtures/Manifest
index 059e92ea4f58..12f5ebae3bc4 100644
--- a/dev-python/testfixtures/Manifest
+++ b/dev-python/testfixtures/Manifest
@@ -5,3 +5,4 @@ DIST testfixtures-4.3.3.tar.gz 86546 SHA256 ffe66d08ef2fdc0be5e6abe1e1d51384ae94
DIST testfixtures-4.4.0.tar.gz 87356 SHA256 41096fe91c2939177f1729783bbfaef9e777ba44e7d8ff819ab1318d78beeba7 SHA512 0fdb87e1fd8311cbab274f4db71ec76767cc9e2f771eefb1a110bf42b07e30fc9edbe2db124742b3102b8f114af2666b0b8726f6330871fd72c7ea2f535d5fed WHIRLPOOL 8b5bb18b682f420ae4b66aa1da9ca0f312bff1974400b586cb2bcae635037e629352b37cfa2d1f8c7f91fd880e726c34d7f3aa532b2e04188f5f99ac7a69e2c1
DIST testfixtures-4.6.0.tar.gz 87322 SHA256 f58ffea34cf0972a3fddcd1873d594d02289587f0ea1d3c1327749f9258cf013 SHA512 cd1e35c907d2f264976161f72c335cc136bec41dd56ee773920eae52a8553fbd7367c9218ba30acccd0a98c067a5aaf675655924f94da60cc190c608714b6bc2 WHIRLPOOL 64cb69d26217cf3748e87fc99029d586b20ee2ce13a8af98454cd33bd4121c021726cb7579b82dfead0b2a281e85fc3906a18ebd2c6a5b6c35c6b1eed49aaa1b
DIST testfixtures-4.7.0.tar.gz 87453 SHA256 214f986a1f590eb67434dd110cc5046f2ec9d6fe0fc9b8a2e7e8203bfe745220 SHA512 7795ac4181018851f31360653e8f6766af2d96db1b453bd395fcdcb8d4ee02c3db644da7e6c83b170d0cca23f2c81f130b56dc086f3b2bb846ccb335cd18aa8e WHIRLPOOL d91def6902dbe297fd94dfc42d1d1b2dceedf851c67cbab771baeb5093bd95e0b03f41f22a68558a7dfde216f6e6d1afa347c7857327a15aa7d4722cae2add9d
+DIST testfixtures-4.9.1.tar.gz 90117 SHA256 e45eef63eb39e63f689ec9d25f03b9bcc201b15e6411f3b73cfe4d0611ad5e1d SHA512 20053d22297b7852382a4f2bf6d76bde6489f788a9073aaae407f68bb6b3d7bdc4a045868cf7c99fd294936768745ee7d652c86a4a96c33fb0e95fa0d96d2a59 WHIRLPOOL 2cabb01d1d11fcf54aac3ba05ed5432bbe0eeb416699b8b4db108a94ce87b1cebe5c5594c350f5e39b1cb4f036dd9577620235b2ddc757ea31c956d3b97f43d3
diff --git a/dev-python/testfixtures/testfixtures-4.9.1.ebuild b/dev-python/testfixtures/testfixtures-4.9.1.ebuild
new file mode 100644
index 000000000000..45d8f0a3ac45
--- /dev/null
+++ b/dev-python/testfixtures/testfixtures-4.9.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
+HOMEPAGE="https://pypi.python.org/pypi/testfixtures/ https://github.com/Simplistix/testfixtures"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pkginfo[${PYTHON_USEDEP}]' python2_7 pypy )
+ )
+ test? (
+ dev-python/manuel[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nose-cover3[${PYTHON_USEDEP}]
+ dev-python/nose_fixes[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ )"
+
+python_prepare_all() {
+ # Makefile comes set pointing at a wrong location
+ sed \
+ -e 's:../bin/sphinx-build:/usr/bin/sphinx-build:' \
+ -i docs/Makefile || die
+ # Prevent un-needed download during build, fix Makefile for doc build
+ sed -e '/'sphinx.ext.intersphinx'/d' -i docs/conf.py || die
+
+ # remove test that tests the stripped zope-component test_components.ComponentsTests
+ rm -f testfixtures/tests/test_components.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests --verbosity=3 || die
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}