summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-17 19:39:47 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-17 20:06:50 +0200
commit22c1a3498b1604f8e12a6a1e3589ccc5af76f593 (patch)
tree1f8afc5340cab4bbe7b2aa3446fdd64dc8c61b40 /dev-python/testpath
parentdev-python/pyproject2setuppy: Bump to v15 (diff)
downloadgentoo-22c1a3498b1604f8e12a6a1e3589ccc5af76f593.tar.gz
gentoo-22c1a3498b1604f8e12a6a1e3589ccc5af76f593.tar.bz2
gentoo-22c1a3498b1604f8e12a6a1e3589ccc5af76f593.zip
dev-python/testpath: Bump to 0.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/testpath')
-rw-r--r--dev-python/testpath/Manifest1
-rw-r--r--dev-python/testpath/testpath-0.5.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/testpath/Manifest b/dev-python/testpath/Manifest
index c2cb49785269..6382fff90072 100644
--- a/dev-python/testpath/Manifest
+++ b/dev-python/testpath/Manifest
@@ -1 +1,2 @@
DIST testpath-0.4.4.tar.gz 92101 BLAKE2B e607fbccf66570ebe29779701bac11048751e9ee8381cd7841ba5dc55e02ee2edc32e8fd8a4a869fdd786f0c4bacdb5e7efc644e0111c24a786631257a08c9cb SHA512 4435c99325d535c713e88b59ce16704e10947232e4eccfe0e792ff9288b65e677417881ce8bbb69577aebb4b9ef793621d8e54898ecb158d07fc22e8445950e2
+DIST testpath-0.5.0.tar.gz 93168 BLAKE2B 864ac80e027192fb1a83f1a15db55fe72729154c7236f2054abfe161be36741614732efbea2a6b4eeb1fb59befa36002d767b4113fab98202ff22330ad15e21d SHA512 d960da04b490b355c5ca9d8e348d81a0d528f13dc7a2b5d6d3c09327a603c1582bce76f7de6d1666b490112306a10d6a19c7979c1119fb726c08c712a08bbcb0
diff --git a/dev-python/testpath/testpath-0.5.0.ebuild b/dev-python/testpath/testpath-0.5.0.ebuild
new file mode 100644
index 000000000000..44cf89905b50
--- /dev/null
+++ b/dev-python/testpath/testpath-0.5.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( pypy3 python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Test utilities for code working with files and commands"
+HOMEPAGE="https://github.com/jupyter/testpath https://testpath.readthedocs.io/en/latest/"
+SRC_URI="https://github.com/jupyter/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ >=dev-python/pyproject2setuppy-15
+ test? (
+ dev-python/pathlib2[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc