summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-23 21:42:29 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-23 22:30:01 +0100
commit5373ec27f3e0643f57a7d24e3670b0db7e0ee07e (patch)
treeabc6a87b5ab90c8f1f36fb1c4268220df84a28b3 /dev-python/testpath
parentapp-admin/awscli: Bump to 1.22.61 (diff)
downloadgentoo-5373ec27f3e0643f57a7d24e3670b0db7e0ee07e.tar.gz
gentoo-5373ec27f3e0643f57a7d24e3670b0db7e0ee07e.tar.bz2
gentoo-5373ec27f3e0643f57a7d24e3670b0db7e0ee07e.zip
dev-python/testpath: Bump to 0.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/testpath')
-rw-r--r--dev-python/testpath/Manifest1
-rw-r--r--dev-python/testpath/testpath-0.6.0.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/testpath/Manifest b/dev-python/testpath/Manifest
index 1a5f559abbe1..01a1957d369f 100644
--- a/dev-python/testpath/Manifest
+++ b/dev-python/testpath/Manifest
@@ -1 +1,2 @@
DIST testpath-0.5.0.tar.gz 93168 BLAKE2B 864ac80e027192fb1a83f1a15db55fe72729154c7236f2054abfe161be36741614732efbea2a6b4eeb1fb59befa36002d767b4113fab98202ff22330ad15e21d SHA512 d960da04b490b355c5ca9d8e348d81a0d528f13dc7a2b5d6d3c09327a603c1582bce76f7de6d1666b490112306a10d6a19c7979c1119fb726c08c712a08bbcb0
+DIST testpath-0.6.0.tar.gz 92307 BLAKE2B 320695b4224803214759a74e64e969a244814f4767eb6092b758ba9fcbfadce81afa3fa5eee65b8c8fe9c54e486d9abf75a18b867883740052c58d1eb2671e23 SHA512 fe13523138c1e67f33a3aa707e81b8cc8b5a720ab231ea2c2407da003178d779a649f664213822022e26325fed4ddf468cf727737b94eb2ebf7315aacbce6857
diff --git a/dev-python/testpath/testpath-0.6.0.ebuild b/dev-python/testpath/testpath-0.6.0.ebuild
new file mode 100644
index 000000000000..1bd8ec23135b
--- /dev/null
+++ b/dev-python/testpath/testpath-0.6.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Test utilities for code working with files and commands"
+HOMEPAGE="https://github.com/jupyter/testpath https://testpath.readthedocs.io/en/latest/"
+SRC_URI="https://github.com/jupyter/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc