summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-08-24 08:22:20 +0200
committerJustin Lecher <jlec@gentoo.org>2015-08-24 12:12:09 +0200
commit7669af3f33e1df2f39e4730b71cd31bc9c673d0a (patch)
tree5bda9e727f127ad6fc2496b6c7eaad15d9c8299d /dev-python/testrepository
parentdev-python/testresources: Add pypy3 support (diff)
downloadgentoo-7669af3f33e1df2f39e4730b71cd31bc9c673d0a.tar.gz
gentoo-7669af3f33e1df2f39e4730b71cd31bc9c673d0a.tar.bz2
gentoo-7669af3f33e1df2f39e4730b71cd31bc9c673d0a.zip
dev-python/testrepository: Add pypy3 support
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/testrepository')
-rw-r--r--dev-python/testrepository/testrepository-0.0.18-r1.ebuild23
1 files changed, 13 insertions, 10 deletions
diff --git a/dev-python/testrepository/testrepository-0.0.18-r1.ebuild b/dev-python/testrepository/testrepository-0.0.18-r1.ebuild
index 411e30fc462e..f2ea60551810 100644
--- a/dev-python/testrepository/testrepository-0.0.18-r1.ebuild
+++ b/dev-python/testrepository/testrepository-0.0.18-r1.ebuild
@@ -3,7 +3,8 @@
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
inherit distutils-r1
@@ -16,17 +17,19 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
IUSE="test"
-RDEPEND=">=dev-python/subunit-0.0.10[${PYTHON_USEDEP}]
- >=dev-python/testtools-0.9.30[${PYTHON_USEDEP}]
- dev-python/fixtures[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/subunit-0.0.10[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.30[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]"
#bzr is listed but presumably req'd for a live repo test run
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- dev-python/testresources[${PYTHON_USEDEP}]
- dev-python/testscenarios[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- )"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/testresources[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )"
# Required for test phase
DISTUTILS_IN_SOURCE_BUILD=1