summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-03-02 11:41:35 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-03-02 11:45:47 +0100
commit524a5dfa42f6ea18d17996bce15b61c1c1a604cb (patch)
tree143696de33a90e95d2619a5bb98d168cd5a32ef6 /dev-python/testresources/testresources-1.0.0.ebuild
parentdev-python/ipdb: Bump (diff)
downloadgentoo-524a5dfa42f6ea18d17996bce15b61c1c1a604cb.tar.gz
gentoo-524a5dfa42f6ea18d17996bce15b61c1c1a604cb.tar.bz2
gentoo-524a5dfa42f6ea18d17996bce15b61c1c1a604cb.zip
dev-python/testresources: Bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/testresources/testresources-1.0.0.ebuild')
-rw-r--r--dev-python/testresources/testresources-1.0.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/testresources/testresources-1.0.0.ebuild b/dev-python/testresources/testresources-1.0.0.ebuild
new file mode 100644
index 000000000000..9121c8a96d1d
--- /dev/null
+++ b/dev-python/testresources/testresources-1.0.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A pyunit extension for managing expensive test resources"
+HOMEPAGE="https://launchpad.net/testresources"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ )"
+RDEPEND=""
+
+python_prepare_all() {
+ sed \
+ -e 's:testBasicSortTests:_&:g' \
+ -i testresources/tests/test_optimising_test_suite.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests --verbose || die "Tests failed under ${EPYTHON}"
+}