summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-29 20:06:25 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-29 20:07:49 +0300
commit21aa8e58454dad82e9752c30309024fdd8dd5400 (patch)
tree7476aa7a3a64a28795fd2c0403f2ea420ffdce51 /dev-python/textdistance
parentdev-python/pylint: add 2.14.4 (diff)
downloadgentoo-21aa8e58454dad82e9752c30309024fdd8dd5400.tar.gz
gentoo-21aa8e58454dad82e9752c30309024fdd8dd5400.tar.bz2
gentoo-21aa8e58454dad82e9752c30309024fdd8dd5400.zip
dev-python/textdistance: add 4.3.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/textdistance')
-rw-r--r--dev-python/textdistance/Manifest1
-rw-r--r--dev-python/textdistance/textdistance-4.3.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/textdistance/Manifest b/dev-python/textdistance/Manifest
index 302ddf4598c8..9c2d9f2bc5d2 100644
--- a/dev-python/textdistance/Manifest
+++ b/dev-python/textdistance/Manifest
@@ -1 +1,2 @@
DIST textdistance-4.2.2.tar.gz 45089 BLAKE2B 8b08db743a56c289cc10a9ceb606612acb2a13d12cd12f9627870a4748c415804bde7c3f1aee54d59a49053731727827dbbd5f4ed6c2cfcc302166575ba382ca SHA512 f181686153e6e8f1541a15ac752e6a86698445713732858e63b6465c96dfeb582d2ea6cad1f7c526a3dc60796d58064355480bc6ced7dc69268a5c0abbfabdb7
+DIST textdistance-4.3.0.gh.tar.gz 45535 BLAKE2B e43ae62b0b7656a6c4f879b1d8e0c34ae6c83705d324aa99bb7ff6e2d0166faf1fed3ee7bc06602388c16c742a1983a4eaee143b09a7c371b9e941d53edca2b5 SHA512 30d68048b1f0b79e584f5f07731e03193af64cb2de3f52882c17154cc027f4ff8d590b994941bd5d62642d4da334ef0739d4bb65b6b12f039a1ee9aef154cde4
diff --git a/dev-python/textdistance/textdistance-4.3.0.ebuild b/dev-python/textdistance/textdistance-4.3.0.ebuild
new file mode 100644
index 000000000000..abcea1dd1ff6
--- /dev/null
+++ b/dev-python/textdistance/textdistance-4.3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Compute distance between the two texts"
+HOMEPAGE="https://github.com/life4/textdistance"
+SRC_URI="
+ https://github.com/life4/textdistance/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/abydos[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/isort[${PYTHON_USEDEP}]
+ dev-python/jellyfish[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/python-levenshtein[${PYTHON_USEDEP}]
+ dev-python/pyxDamerauLevenshtein[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest
+
+EPYTEST_DESELECT=(
+ tests/test_external.py
+)