summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-04-08 15:16:59 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-04-09 14:49:27 +0300
commit2e197cab48ba35778cdfb57267774c712d6e12f2 (patch)
tree0836e9b94e5703dd70bb64d5d7e7cb00a9344418 /dev-python/textdistance
parentdev-python/abydos: add py3.9 (diff)
downloadgentoo-2e197cab48ba35778cdfb57267774c712d6e12f2.tar.gz
gentoo-2e197cab48ba35778cdfb57267774c712d6e12f2.tar.bz2
gentoo-2e197cab48ba35778cdfb57267774c712d6e12f2.zip
dev-python/textdistance: add py3.9
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/textdistance')
-rw-r--r--dev-python/textdistance/textdistance-4.2.1-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/textdistance/textdistance-4.2.1-r1.ebuild b/dev-python/textdistance/textdistance-4.2.1-r1.ebuild
new file mode 100644
index 000000000000..3628185a3371
--- /dev/null
+++ b/dev-python/textdistance/textdistance-4.2.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Compute distance between the two texts"
+HOMEPAGE="https://github.com/life4/textdistance"
+SRC_URI="https://github.com/life4/textdistance/archive/v.${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="test? (
+ dev-python/abydos[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/isort[${PYTHON_USEDEP}]
+ dev-python/jellyfish[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/python-levenshtein[${PYTHON_USEDEP}]
+ dev-python/pyxDamerauLevenshtein[${PYTHON_USEDEP}]
+)"
+
+S="${WORKDIR}/${PN}-v.${PV}"
+
+distutils_enable_tests --install pytest
+
+python_prepare_all() {
+ # RuntimeError: cannot import distance.hamming
+ # these optional things are missing at the moment
+ sed -i -e 's:test_compare:_&:' \
+ -e 's:test_qval:_&:' \
+ -e 's:test_list_of_numbers:_&:' \
+ tests/test_external.py || die
+
+ distutils-r1_python_prepare_all
+}