summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-16 09:34:16 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-16 09:34:27 +0300
commit8264e1b109f5c80c7f6f408033b16ab2a2845906 (patch)
tree83b151302f8215de70eb1c40cd729ac952d75002 /dev-python/textdistance
parentdev-python/lunr: enable py3.10 (diff)
downloadgentoo-8264e1b109f5c80c7f6f408033b16ab2a2845906.tar.gz
gentoo-8264e1b109f5c80c7f6f408033b16ab2a2845906.tar.bz2
gentoo-8264e1b109f5c80c7f6f408033b16ab2a2845906.zip
dev-python/textdistance: enable py3.10, small cleanup
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/textdistance')
-rw-r--r--dev-python/textdistance/textdistance-4.2.1-r1.ebuild19
1 files changed, 5 insertions, 14 deletions
diff --git a/dev-python/textdistance/textdistance-4.2.1-r1.ebuild b/dev-python/textdistance/textdistance-4.2.1-r1.ebuild
index 9466d5a900d9..aea07b6f2fd3 100644
--- a/dev-python/textdistance/textdistance-4.2.1-r1.ebuild
+++ b/dev-python/textdistance/textdistance-4.2.1-r1.ebuild
@@ -3,13 +3,13 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Compute distance between the two texts"
HOMEPAGE="https://github.com/life4/textdistance"
SRC_URI="https://github.com/life4/textdistance/archive/v.${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-v.${PV}"
LICENSE="MIT"
SLOT="0"
@@ -25,17 +25,8 @@ BDEPEND="test? (
dev-python/pyxDamerauLevenshtein[${PYTHON_USEDEP}]
)"
-S="${WORKDIR}/${PN}-v.${PV}"
-
distutils_enable_tests --install pytest
-python_prepare_all() {
- # RuntimeError: cannot import distance.hamming
- # these optional things are missing at the moment
- sed -i -e 's:test_compare:_&:' \
- -e 's:test_qval:_&:' \
- -e 's:test_list_of_numbers:_&:' \
- tests/test_external.py || die
-
- distutils-r1_python_prepare_all
-}
+EPYTEST_DESELECT=(
+ tests/test_external.py
+)