summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-07-13 10:15:29 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-07-13 10:16:00 +0300
commitd8b385de7b770d2ddbece439b49ddfa344676e71 (patch)
treec8a3d1db1630d153a8962cc9113db1d0e76f39be /dev-python/texttable
parentdev-python/cjkwrap: EAPI-7 bump, python-3.9 supp, ebuild cleaning (diff)
downloadgentoo-d8b385de7b770d2ddbece439b49ddfa344676e71.tar.gz
gentoo-d8b385de7b770d2ddbece439b49ddfa344676e71.tar.bz2
gentoo-d8b385de7b770d2ddbece439b49ddfa344676e71.zip
dev-python/texttable: python3.9, use d_e_t, use optfeature, clean file
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/texttable')
-rw-r--r--dev-python/texttable/texttable-1.6.2-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/texttable/texttable-1.6.2-r1.ebuild b/dev-python/texttable/texttable-1.6.2-r1.ebuild
new file mode 100644
index 000000000000..ca525083381b
--- /dev/null
+++ b/dev-python/texttable/texttable-1.6.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Module for creating simple ASCII tables"
+HOMEPAGE="https://github.com/foutaise/texttable https://pypi.org/project/texttable/"
+SRC_URI="https://github.com/foutaise/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/wcwidth[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ pytest -vv tests.py || die
+}
+
+pkg_postinst() {
+ elog "Optional features: "
+ optfeature "better wrapping of CJK text" dev-python/cjkwrap
+}