summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-29 09:52:04 +0000
committerSam James <sam@gentoo.org>2020-12-29 09:52:04 +0000
commit5e3f2bedb78f4adfec1050ba03105f572e3e8866 (patch)
tree108f3b19956fdd9bdd3fb8673ac88defc45099d5 /dev-python/theano-pymc
parentmedia-fonts/fontawesome: Stabilize 5.15.1 ALLARCHES, #762068 (diff)
downloadgentoo-5e3f2bedb78f4adfec1050ba03105f572e3e8866.tar.gz
gentoo-5e3f2bedb78f4adfec1050ba03105f572e3e8866.tar.bz2
gentoo-5e3f2bedb78f4adfec1050ba03105f572e3e8866.zip
dev-python/theano-pymc: bump to 1.0.14
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/theano-pymc')
-rw-r--r--dev-python/theano-pymc/Manifest1
-rw-r--r--dev-python/theano-pymc/theano-pymc-1.0.14.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/theano-pymc/Manifest b/dev-python/theano-pymc/Manifest
index 1ff0b282387f..033bccb6c7f3 100644
--- a/dev-python/theano-pymc/Manifest
+++ b/dev-python/theano-pymc/Manifest
@@ -1 +1,2 @@
DIST theano-pymc-1.0.13.tar.gz 12975871 BLAKE2B 71528868885084d7c37f1f5cc5156aca5e764d09f0dc57aa46e21240ee2959aafb5882aef8977d9f215b051265d0d9bc3a7097ac0bb6d427cfc076ea6f591905 SHA512 da25e386965695a5630c54a671a7a573d0f0fae2eeeacf4f65130e4e4caf416373852ac14b1eb07ae39c194febe854d71fffe2adc24c348f64a4b73b43564229
+DIST theano-pymc-1.0.14.tar.gz 12979426 BLAKE2B e6db87a348d6e7003f8b1ff4e0634335d53d734ea922951edeaab06ec54d51f1d7930a03f6dca14979930abb6212f873d606a9adada46d5b606854c5d8a6c6a5 SHA512 4ddfe5978f33cea96b20763cb01eecf1ec6c0c6b97ac892d647e28b607e61b11862739e5836356ab87e2002e992febe35ce9e1e72d37732074be2dbed64b50b9
diff --git a/dev-python/theano-pymc/theano-pymc-1.0.14.ebuild b/dev-python/theano-pymc/theano-pymc-1.0.14.ebuild
new file mode 100644
index 000000000000..e66b350a5eea
--- /dev/null
+++ b/dev-python/theano-pymc/theano-pymc-1.0.14.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_9 )
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Library for operating on mathematical expressions with multi-dimensional arrays"
+HOMEPAGE="https://github.com/pymc-devs/Theano-PyMC"
+SRC_URI="https://github.com/pymc-devs/Theano-PyMC/archive/rel-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/Theano-PyMC-rel-${PV}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx doc 'dev-python/sphinx_rtd_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e "s/, 'flake8'//" setup.py || die
+ sed -i -e "s/tests.\*/tests\*/" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "GPU code generation/execution on NVIDIA gpus" dev-util/nvidia-cuda-toolkit dev-util/nvidia-cuda-sdk
+ optfeature "GPU/CPU code generation on CUDA and OpenCL devices" dev-libs/libgpuarray dev-python/pycuda
+}