summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-12-22 09:52:43 +0100
committerSam James <sam@gentoo.org>2020-12-24 02:01:23 +0000
commitf709cad3fec1092ce8357bdaead9da1bd1fdba04 (patch)
treec1718988ceb29ab7cf035e851dc5d8aaea76fd55 /dev-python/theano-pymc
parentmedia-gfx/darktable: fix manifest (diff)
downloadgentoo-f709cad3fec1092ce8357bdaead9da1bd1fdba04.tar.gz
gentoo-f709cad3fec1092ce8357bdaead9da1bd1fdba04.tar.bz2
gentoo-f709cad3fec1092ce8357bdaead9da1bd1fdba04.zip
dev-python/theano-pymc: Replacement for dev-python/theano
* Python library for operating with mathematical expressions involving multi-dimensional arrays Closes: https://bugs.gentoo.org/759940 Bug: https://bugs.gentoo.org/738416 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Closes: https://github.com/gentoo/gentoo/pull/18763 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/theano-pymc')
-rw-r--r--dev-python/theano-pymc/Manifest1
-rw-r--r--dev-python/theano-pymc/metadata.xml12
-rw-r--r--dev-python/theano-pymc/theano-pymc-1.0.13.ebuild45
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/theano-pymc/Manifest b/dev-python/theano-pymc/Manifest
new file mode 100644
index 000000000000..1ff0b282387f
--- /dev/null
+++ b/dev-python/theano-pymc/Manifest
@@ -0,0 +1 @@
+DIST theano-pymc-1.0.13.tar.gz 12975871 BLAKE2B 71528868885084d7c37f1f5cc5156aca5e764d09f0dc57aa46e21240ee2959aafb5882aef8977d9f215b051265d0d9bc3a7097ac0bb6d427cfc076ea6f591905 SHA512 da25e386965695a5630c54a671a7a573d0f0fae2eeeacf4f65130e4e4caf416373852ac14b1eb07ae39c194febe854d71fffe2adc24c348f64a4b73b43564229
diff --git a/dev-python/theano-pymc/metadata.xml b/dev-python/theano-pymc/metadata.xml
new file mode 100644
index 000000000000..00af8f28ecf4
--- /dev/null
+++ b/dev-python/theano-pymc/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">Theano-PyMC</remote-id>
+ <remote-id type="github">pymc-devs/Theano-PyMC</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/theano-pymc/theano-pymc-1.0.13.ebuild b/dev-python/theano-pymc/theano-pymc-1.0.13.ebuild
new file mode 100644
index 000000000000..509edfe62e17
--- /dev/null
+++ b/dev-python/theano-pymc/theano-pymc-1.0.13.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for operating with mathematical expressions involving multi-dimensional arrays"
+HOMEPAGE="https://github.com/pymc-devs/Theano-PyMC"
+SRC_URI="https://github.com/pymc-devs/Theano-PyMC/archive/rel-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/Theano-PyMC-rel-${PV}
+
+distutils_enable_sphinx doc \
+ 'dev-python/sphinx_rtd_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e "s/, 'flake8'//" setup.py || die
+ sed -i -e "s/tests.\*/tests\*/" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die
+}
+
+pkg_postinst() {
+ optfeature "GPU code generation/execution on NVIDIA gpus" dev-util/nvidia-cuda-toolkit dev-util/nvidia-cuda-sdk
+ optfeature "GPU/CPU code generation on CUDA and OpenCL devices" dev-libs/libgpuarray dev-python/pycuda
+}