summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-04 15:21:19 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-04 15:21:27 +0100
commitf0effe24b87d849eadbc3ba1dd8e8226b0e70fad (patch)
treed37a7df06308e4b5946f263fdf6914f480db082e /dev-python/theano
parentdev-python/theano: Chop DESCRIPTION to 80 chars (diff)
downloadgentoo-f0effe24b87d849eadbc3ba1dd8e8226b0e70fad.tar.gz
gentoo-f0effe24b87d849eadbc3ba1dd8e8226b0e70fad.tar.bz2
gentoo-f0effe24b87d849eadbc3ba1dd8e8226b0e70fad.zip
dev-python/theano: Version Bump
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=573754 Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/theano')
-rw-r--r--dev-python/theano/Manifest1
-rw-r--r--dev-python/theano/theano-0.7.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/theano/Manifest b/dev-python/theano/Manifest
index 41b7d8ab8dd6..eb5e9e17510f 100644
--- a/dev-python/theano/Manifest
+++ b/dev-python/theano/Manifest
@@ -1 +1,2 @@
DIST Theano-0.6.0.tar.gz 1763756 SHA256 aaa75f9a9b7bf50f09ddcc01fb993cf47513179d0a7bee3d96bfeebd66e76083 SHA512 6333c673df809bed3af952e0759cce4878ed21684367c6eb20e422363c7c5696ea59239ff6a448c6a32771b1069d441b0e3d049f9708ae69d790412303b8ebbd WHIRLPOOL 946fcacb87b7745e72282f5f7e6b67db5fd0e365f55b2c97a8e9e506e30986d90da7c3789636892ca316da33f4f064f99d31fc3771678457dd609fd0c43d9010
+DIST Theano-0.7.0.tar.gz 1985387 SHA256 05b0f6d2467735abea13bdc5c2c1ce3c53f1b89f9ebc5a43abdf71f88cf818b3 SHA512 6e6bf9afdebf3c281d71f5ceda73792e0a52b403b18776a639665767ac73ac4920b5042e29d656d517b8f023e5f9cd5a27086e0456dc40c42abf6f3569da3f06 WHIRLPOOL b79906e39eb8f7cad26160148465b4719d1011e1a4626c98fdb55cd273ff289b0c01278d51fdc8271b71434be0fd036f8259a315b07639e9ad83d1e3bf313687
diff --git a/dev-python/theano/theano-0.7.0.ebuild b/dev-python/theano/theano-0.7.0.ebuild
new file mode 100644
index 000000000000..46e594577196
--- /dev/null
+++ b/dev-python/theano/theano-0.7.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 versionator
+
+MYPN=Theano
+MYP=${MYPN}-$(replace_version_separator 3 '')
+
+DESCRIPTION="Define and optimize multi-dimensional arrays mathematical expressions"
+HOMEPAGE="https://github.com/Theano/Theano"
+SRC_URI="mirror://pypi/${MYPN:0:1}/${MYPN}/${MYP}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+IUSE="test"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/numpy-1.6.2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-0.11[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MYP}"
+
+python_prepare_all() {
+ find -type f -name "*.py" -exec \
+ sed \
+ -e 's:theano.compat.six:six:g' \
+ -i '{}' + || die
+
+ rm ${PN}/compat/six.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests --verbosity=3 || die
+}