summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-04 19:54:28 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-04 20:54:55 +0300
commit7e4503a8df7648221e201d2be5f8b5524430b4aa (patch)
tree9249cfe388ff84620ca38cdb8d6200789bbce45a /dev-python/tifffile
parentdev-python/flake8: add 5.0.4 (diff)
downloadgentoo-7e4503a8df7648221e201d2be5f8b5524430b4aa.tar.gz
gentoo-7e4503a8df7648221e201d2be5f8b5524430b4aa.tar.bz2
gentoo-7e4503a8df7648221e201d2be5f8b5524430b4aa.zip
dev-python/tifffile: add 2022.8.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/tifffile')
-rw-r--r--dev-python/tifffile/Manifest1
-rw-r--r--dev-python/tifffile/tifffile-2022.8.3.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/tifffile/Manifest b/dev-python/tifffile/Manifest
index 6efb9b6c69df..28a36f324b70 100644
--- a/dev-python/tifffile/Manifest
+++ b/dev-python/tifffile/Manifest
@@ -1,3 +1,4 @@
DIST tifffile-2022.5.4.gh.tar.gz 290116 BLAKE2B 4c608ad38ad7ada0e1b41512eae7b4109680cab1f5623ea3cd6c01dfe17b534b518868ee21879ecfa9909f7680a04fbb63967b5c8064062cc325286baaaccb6b SHA512 cc6139872c42e0e2840a9774989b5cba57ef8957e2efa4349e7b224c61ebb8ad34287b9305dddd85b1239d03be4ada73526259b038c19c73513007e5f63d224d
DIST tifffile-2022.7.28.gh.tar.gz 309010 BLAKE2B 4a52a688ce7f09265592f8bd2bed2eaf9648304908aa1b190c07a22b58f10bb3f71f9ea1f9a612a2592f75f457acc04cc2139ef0cbd75ea40a7e91408075062b SHA512 12647884cb77fc8e414c09aface82def1ad2bb0a11a1f17fa00e6954cf565a906b6a8c9e861d0a476a86ef8ea25da12d1069199109cb84030d312021d722f23e
DIST tifffile-2022.7.31.gh.tar.gz 309561 BLAKE2B 9a7c2584dbf7741d3c77c7dac3a6a16393dc5630ac97fa2d5110ad7458c04b60dbb618075718856f7ad7846470430c6f978a17dc1706a58441460b28a57d0c78 SHA512 6e935b46cf404cc027e6430e304c3993e74b6ae577817efc68fff525de96b01f13b14cfce9a21c5d25a082bdcb56e4b4e6ab9803959357ec6bd7a26bf0d0503a
+DIST tifffile-2022.8.3.gh.tar.gz 310296 BLAKE2B ae503d79105ff5172879cb1b048b061b7ac795efebe8c3fe44792a33fb3fb14d1d6ba5e57cdaf5b8df6623b512efc3a8979474b3327b932087d898226b786b65 SHA512 7040ff4cdcf4de33bd158172086a31072084dd43ebd9b3277394ac7f50044af2447e8871a4f9df7132b068e0bea71ab4beefbbbb0e91dfaf3bdb07337cb7ec0a
diff --git a/dev-python/tifffile/tifffile-2022.8.3.ebuild b/dev-python/tifffile/tifffile-2022.8.3.ebuild
new file mode 100644
index 000000000000..867f25de5f9d
--- /dev/null
+++ b/dev-python/tifffile/tifffile-2022.8.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read and write TIFF files"
+HOMEPAGE="
+ https://pypi.org/project/tifffile/
+ https://github.com/cgohlke/tifffile/
+ https://www.cgohlke.com/
+"
+SRC_URI="
+ https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/dask[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/test_tifffile.py::test_class_omexml
+ tests/test_tifffile.py::test_class_omexml_fail
+ tests/test_tifffile.py::test_class_omexml_modulo
+ tests/test_tifffile.py::test_class_omexml_attributes
+ tests/test_tifffile.py::test_class_omexml_multiimage
+ tests/test_tifffile.py::test_write_ome
+ tests/test_tifffile.py::test_write_ome_manual
+ # requires tons of free space
+ tests/test_tifffile.py::test_write_3gb
+ tests/test_tifffile.py::test_write_bigtiff
+ 'tests/test_tifffile.py::test_write_imagej_raw'
+)