summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-30 09:09:42 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-30 09:34:59 +0200
commita9da18e153695ad23298d9126ab6a98c0a87e29c (patch)
tree37e7545865cf220220a950c9458073aeed32d611 /dev-python/tifffile
parentdev-python/ipython: Bump to 8.3.0 (diff)
downloadgentoo-a9da18e153695ad23298d9126ab6a98c0a87e29c.tar.gz
gentoo-a9da18e153695ad23298d9126ab6a98c0a87e29c.tar.bz2
gentoo-a9da18e153695ad23298d9126ab6a98c0a87e29c.zip
dev-python/tifffile: Bump to 2022.4.28
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tifffile')
-rw-r--r--dev-python/tifffile/Manifest1
-rw-r--r--dev-python/tifffile/tifffile-2022.4.28.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/tifffile/Manifest b/dev-python/tifffile/Manifest
index d9f7e01a597b..f5944bea68cf 100644
--- a/dev-python/tifffile/Manifest
+++ b/dev-python/tifffile/Manifest
@@ -2,4 +2,5 @@ DIST tifffile-2022.3.16.gh.tar.gz 263653 BLAKE2B fcd30e2fd38a12438332badb17e937a
DIST tifffile-2022.3.25.gh.tar.gz 265082 BLAKE2B dd5f3705cb7203fe943b97a5ed5c000b44abf48ec748f38a1468e27e82bd980e4100dd14af5cfd6af5bdee9d0036c5dce37efca1e515f2eb283c0e221150915a SHA512 dc9018991989ca4b89be6f315aaa45ff2fb94c504dd4c1790af1ec68e05a1da85560f5098df2f460b726cea0d4b0e4fc3f12d493dc1a1db8e2cc35d86f547ddf
DIST tifffile-2022.4.22.gh.tar.gz 280049 BLAKE2B d1d45e7a28c83ca52708aea64c5b7fffdab61405bf9aa2f87d1c3ef347e4057f3081e4f5b6df9de70ad35ec3dd9a17f30a763124338549bda0d93207c59bc7b5 SHA512 75488d9f15c98e8f9824ac4e538f7d2d75dbf06479ea1aee0a7f33bca71be0b3beeb32d3e8a4dcf5e09349ff415faff17d20ce312e43c80209d5c78cf8554c50
DIST tifffile-2022.4.26.gh.tar.gz 283249 BLAKE2B 740cbee481bac327e63e4d574edc8667a7fab7b53311fcba719a8930ee5827fc8fb4888c881e20453c34635211105447fca12e0d3ce6cfcad5f38efc89c35b09 SHA512 f1e38ae821559c2807c6f299eae43255ec8a164119cb1a5ba2bf80b281b83ba7c629504efa2a2d36ef26edf14577dd7234c1c9bba8168503e4298dafe4fbc743
+DIST tifffile-2022.4.28.gh.tar.gz 285773 BLAKE2B 245f24762d8b77166122440e205df4c0f4d5e55334ed9a30986d2a1baf21aba663ec126a0ac44f21931572e186f779f915ba4a3d6ae43d9c4897d5aa9a231440 SHA512 18a35e27976c88173931d2898a1a3d62d96d5ab844b2a585922f26838e1b4574277dff3ccbc2baa7898165b0312699a857da251b00ad8050624f49a3d29d00ab
DIST tifffile-2022.4.8.gh.tar.gz 266725 BLAKE2B 3ac30337c1c7f26e32335a6d7756b4bf2d961f1e96badbc4ca8e9e5ee344513c61900d507f4098e4f5181b2c95134d0a74b646ce611cf9d3d3b5cc644ed70809 SHA512 1d12ca48dcc9fd8de5f3aa28cdd64a7735493b957d174f8ae49cb8a918075e6b50d4034ad9507d3b9ddd8ed1c595ec9fdace0986421b1993371cfe045698d578
diff --git a/dev-python/tifffile/tifffile-2022.4.28.ebuild b/dev-python/tifffile/tifffile-2022.4.28.ebuild
new file mode 100644
index 000000000000..c7b39355f0d6
--- /dev/null
+++ b/dev-python/tifffile/tifffile-2022.4.28.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read and write TIFF files"
+HOMEPAGE="
+ https://pypi.org/project/tifffile/
+ https://github.com/cgohlke/tifffile/
+ https://www.lfd.uci.edu/~gohlke/
+"
+SRC_URI="
+ https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/dask[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/test_tifffile.py::test_class_omexml
+ tests/test_tifffile.py::test_class_omexml_fail
+ tests/test_tifffile.py::test_class_omexml_modulo
+ tests/test_tifffile.py::test_class_omexml_attributes
+ tests/test_tifffile.py::test_class_omexml_multiimage
+ tests/test_tifffile.py::test_write_ome
+ tests/test_tifffile.py::test_write_ome_manual
+ # requires tons of free space
+ tests/test_tifffile.py::test_write_3gb
+ tests/test_tifffile.py::test_write_bigtiff
+ 'tests/test_tifffile.py::test_write_imagej_raw'
+)