summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-04 09:26:56 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-04 10:19:39 +0200
commitd5ae9bd3f5face6a65dda1d367f4757d4bd5cbaf (patch)
tree2f8bb55c5a9a3530d6d61c39c4823274c2c11476 /dev-python/tifffile
parentdev-python/tifffile: Remove old (diff)
downloadgentoo-d5ae9bd3f5face6a65dda1d367f4757d4bd5cbaf.tar.gz
gentoo-d5ae9bd3f5face6a65dda1d367f4757d4bd5cbaf.tar.bz2
gentoo-d5ae9bd3f5face6a65dda1d367f4757d4bd5cbaf.zip
dev-python/tifffile: Bump to 2022.5.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tifffile')
-rw-r--r--dev-python/tifffile/Manifest1
-rw-r--r--dev-python/tifffile/tifffile-2022.5.4.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/tifffile/Manifest b/dev-python/tifffile/Manifest
index 24da938820e5..8f31cd057c65 100644
--- a/dev-python/tifffile/Manifest
+++ b/dev-python/tifffile/Manifest
@@ -1 +1,2 @@
DIST tifffile-2022.4.28.gh.tar.gz 285773 BLAKE2B 245f24762d8b77166122440e205df4c0f4d5e55334ed9a30986d2a1baf21aba663ec126a0ac44f21931572e186f779f915ba4a3d6ae43d9c4897d5aa9a231440 SHA512 18a35e27976c88173931d2898a1a3d62d96d5ab844b2a585922f26838e1b4574277dff3ccbc2baa7898165b0312699a857da251b00ad8050624f49a3d29d00ab
+DIST tifffile-2022.5.4.gh.tar.gz 290116 BLAKE2B 4c608ad38ad7ada0e1b41512eae7b4109680cab1f5623ea3cd6c01dfe17b534b518868ee21879ecfa9909f7680a04fbb63967b5c8064062cc325286baaaccb6b SHA512 cc6139872c42e0e2840a9774989b5cba57ef8957e2efa4349e7b224c61ebb8ad34287b9305dddd85b1239d03be4ada73526259b038c19c73513007e5f63d224d
diff --git a/dev-python/tifffile/tifffile-2022.5.4.ebuild b/dev-python/tifffile/tifffile-2022.5.4.ebuild
new file mode 100644
index 000000000000..c7b39355f0d6
--- /dev/null
+++ b/dev-python/tifffile/tifffile-2022.5.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read and write TIFF files"
+HOMEPAGE="
+ https://pypi.org/project/tifffile/
+ https://github.com/cgohlke/tifffile/
+ https://www.lfd.uci.edu/~gohlke/
+"
+SRC_URI="
+ https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/dask[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/test_tifffile.py::test_class_omexml
+ tests/test_tifffile.py::test_class_omexml_fail
+ tests/test_tifffile.py::test_class_omexml_modulo
+ tests/test_tifffile.py::test_class_omexml_attributes
+ tests/test_tifffile.py::test_class_omexml_multiimage
+ tests/test_tifffile.py::test_write_ome
+ tests/test_tifffile.py::test_write_ome_manual
+ # requires tons of free space
+ tests/test_tifffile.py::test_write_3gb
+ tests/test_tifffile.py::test_write_bigtiff
+ 'tests/test_tifffile.py::test_write_imagej_raw'
+)