summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2021-03-20 09:51:38 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-03-20 10:25:09 +0200
commit552260c358cc56f98629e4b64c0254974ca0437f (patch)
tree5829940f14168f08a6b572cf56869b1348897d9d /dev-python/tikzplotlib
parentdev-python/spyder: drop 4.2.0, 4.2.1 (diff)
downloadgentoo-552260c358cc56f98629e4b64c0254974ca0437f.tar.gz
gentoo-552260c358cc56f98629e4b64c0254974ca0437f.tar.bz2
gentoo-552260c358cc56f98629e4b64c0254974ca0437f.zip
dev-python/tikzplotlib: drop 0.9.6, 0.9.7
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/tikzplotlib')
-rw-r--r--dev-python/tikzplotlib/Manifest2
-rw-r--r--dev-python/tikzplotlib/tikzplotlib-0.9.6.ebuild60
-rw-r--r--dev-python/tikzplotlib/tikzplotlib-0.9.7.ebuild42
3 files changed, 0 insertions, 104 deletions
diff --git a/dev-python/tikzplotlib/Manifest b/dev-python/tikzplotlib/Manifest
index c1a7e0846ef9..9579a28104af 100644
--- a/dev-python/tikzplotlib/Manifest
+++ b/dev-python/tikzplotlib/Manifest
@@ -1,3 +1 @@
-DIST tikzplotlib-0.9.6.tar.gz 589081 BLAKE2B aacd1374caed3dc86e6a93479b7ed0d0a79a2f96acc3817e630860794dc2f77c0d908d5765ebd500160d8c459b51131645f3633a084627b55aa2f26f5de87add SHA512 447dcd9da8d5cebf68b9f1a1f06d82370d5adf731524ea17c4f570bfd76dfce06e65f92df0ead732a02b42d9bdf6d0fde9e004bff50204cc5e33cca6c014a257
-DIST tikzplotlib-0.9.7.tar.gz 589052 BLAKE2B 2960ca341364c003e6c708fa967209c4ab13847f2b7524b926985d73ab146777b314e3df2066c8dcab2ff4c1eb8a46dc4a89f1b85578650cde8c9fb5de5743e9 SHA512 0903f774e3f95612b9b68b4e2254f2c0403e5c603dd41445e359587c4e917c373a12485bc0b8ba30b354eb7b93bb754531489c898dbc4479466c071a2f9b0f3d
DIST tikzplotlib-0.9.8.tar.gz 589858 BLAKE2B 81bb2ece7d3f5976d928095caa3d8d51b619c97a4b36eea14f4b4477d31e78a978c2eeab81e9829bb9113e70f0035a572a82a229fea61ee08530d57334fda986 SHA512 a2b25d9820fd8185d4e7a03fb0669fa4c9b35aac9b371b0a873174d615bd40615f1fafa4208d2019af0b7ffe80a8eec6b56ad6075104f6c3a4f8f237ad5b4466
diff --git a/dev-python/tikzplotlib/tikzplotlib-0.9.6.ebuild b/dev-python/tikzplotlib/tikzplotlib-0.9.6.ebuild
deleted file mode 100644
index c6df920586bc..000000000000
--- a/dev-python/tikzplotlib/tikzplotlib-0.9.6.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 2019-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Convert matplotlib figures into TikZ/PGFPlots"
-HOMEPAGE="https://github.com/nschloe/tikzplotlib"
-SRC_URI="https://github.com/nschloe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- app-text/texlive[extra]
- $( python_gen_cond_dep \
- 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' python3_7 )
- dev-python/matplotlib[latex,${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- dev-python/wheel[${PYTHON_USEDEP}]
- test? (
- dev-python/exdown[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
-)"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx doc dev-python/mock
-
-python_prepare_all() {
- # setup.py was removed in commit f04323cfa575caf8a25a9236f55fe6baf1a33b20
- # for some reason, DISTUTULS_USE_SETUPTOOLS="pyproject.toml" is not working
- # it complains about file not found, setup.cfg does exist
-
- cat > setup.py <<EOF || die
-from setuptools import setup
-
-if __name__ == "__main__":
- setup()
-EOF
-
- # Lots of TeX errors
- rm test/test_patches.py || die
- rm test/test_context.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local -x MPLBACKEND=Agg
- virtx pytest -vv
-}
diff --git a/dev-python/tikzplotlib/tikzplotlib-0.9.7.ebuild b/dev-python/tikzplotlib/tikzplotlib-0.9.7.ebuild
deleted file mode 100644
index eec9580243fc..000000000000
--- a/dev-python/tikzplotlib/tikzplotlib-0.9.7.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 2019-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Convert matplotlib figures into TikZ/PGFPlots"
-HOMEPAGE="https://github.com/nschloe/tikzplotlib"
-SRC_URI="https://github.com/nschloe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- app-text/texlive[extra]
- $( python_gen_cond_dep \
- 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' python3_7 )
- dev-python/matplotlib[latex,${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- dev-python/wheel[${PYTHON_USEDEP}]
- test? (
- dev-python/exdown[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
-)"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx doc dev-python/mock
-
-python_test() {
- local -x MPLBACKEND=Agg
- virtx pytest -vv
-}