summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-05 21:33:47 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-05 22:28:26 +0100
commit558b47c9624d890f0643bd251d8850ff7ec62167 (patch)
tree2adbc42d7d3166d1b348236b43f8bcc3114d0c96 /dev-python/tikzplotlib
parentdev-python/ubelt: Bump to 0.9.5 (diff)
downloadgentoo-558b47c9624d890f0643bd251d8850ff7ec62167.tar.gz
gentoo-558b47c9624d890f0643bd251d8850ff7ec62167.tar.bz2
gentoo-558b47c9624d890f0643bd251d8850ff7ec62167.zip
dev-python/tikzplotlib: Bump to 0.9.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tikzplotlib')
-rw-r--r--dev-python/tikzplotlib/Manifest1
-rw-r--r--dev-python/tikzplotlib/tikzplotlib-0.9.7.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/tikzplotlib/Manifest b/dev-python/tikzplotlib/Manifest
index 5a84f468a4e0..952d9609308d 100644
--- a/dev-python/tikzplotlib/Manifest
+++ b/dev-python/tikzplotlib/Manifest
@@ -1 +1,2 @@
DIST tikzplotlib-0.9.6.tar.gz 589081 BLAKE2B aacd1374caed3dc86e6a93479b7ed0d0a79a2f96acc3817e630860794dc2f77c0d908d5765ebd500160d8c459b51131645f3633a084627b55aa2f26f5de87add SHA512 447dcd9da8d5cebf68b9f1a1f06d82370d5adf731524ea17c4f570bfd76dfce06e65f92df0ead732a02b42d9bdf6d0fde9e004bff50204cc5e33cca6c014a257
+DIST tikzplotlib-0.9.7.tar.gz 589052 BLAKE2B 2960ca341364c003e6c708fa967209c4ab13847f2b7524b926985d73ab146777b314e3df2066c8dcab2ff4c1eb8a46dc4a89f1b85578650cde8c9fb5de5743e9 SHA512 0903f774e3f95612b9b68b4e2254f2c0403e5c603dd41445e359587c4e917c373a12485bc0b8ba30b354eb7b93bb754531489c898dbc4479466c071a2f9b0f3d
diff --git a/dev-python/tikzplotlib/tikzplotlib-0.9.7.ebuild b/dev-python/tikzplotlib/tikzplotlib-0.9.7.ebuild
new file mode 100644
index 000000000000..b1d6c8827e1d
--- /dev/null
+++ b/dev-python/tikzplotlib/tikzplotlib-0.9.7.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Convert matplotlib figures into TikZ/PGFPlots"
+HOMEPAGE="https://github.com/nschloe/tikzplotlib"
+SRC_URI="https://github.com/nschloe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-text/texlive[extra]
+ $( python_gen_cond_dep \
+ 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' python3_7 )
+ dev-python/matplotlib[latex,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/wheel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/exdown[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/mock
+
+python_prepare_all() {
+ # setup.py was removed in commit f04323cfa575caf8a25a9236f55fe6baf1a33b20
+ # for some reason, DISTUTULS_USE_SETUPTOOLS="pyproject.toml" is not working
+ # it complains about file not found, setup.cfg does exist
+
+ cat > setup.py <<EOF || die
+from setuptools import setup
+
+if __name__ == "__main__":
+ setup()
+EOF
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x MPLBACKEND=Agg
+ virtx pytest -vv
+}