summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-01-14 12:16:12 +0100
committerDavid Seifert <soap@gentoo.org>2023-01-14 12:16:12 +0100
commit278d7b68a749aadb4687bca812f8780d67f05572 (patch)
treeb118a0a7c4cad003cf6907e51b9ee23bf3501d55 /dev-python/time-machine
parentwww-client/vivaldi-snapshot: Drop old 5.7.2887.3 (diff)
downloadgentoo-278d7b68a749aadb4687bca812f8780d67f05572.tar.gz
gentoo-278d7b68a749aadb4687bca812f8780d67f05572.tar.bz2
gentoo-278d7b68a749aadb4687bca812f8780d67f05572.zip
dev-python/time-machine: remove py3.8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/time-machine')
-rw-r--r--dev-python/time-machine/time-machine-2.8.2.ebuild11
-rw-r--r--dev-python/time-machine/time-machine-2.9.0.ebuild9
2 files changed, 3 insertions, 17 deletions
diff --git a/dev-python/time-machine/time-machine-2.8.2.ebuild b/dev-python/time-machine/time-machine-2.8.2.ebuild
index e7b8033bcf4c..4f651ae7e543 100644
--- a/dev-python/time-machine/time-machine-2.8.2.ebuild
+++ b/dev-python/time-machine/time-machine-2.8.2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
@@ -25,12 +25,5 @@ KEYWORDS="~amd64 ~ppc"
RDEPEND="
dev-python/python-dateutil[${PYTHON_USEDEP}]
"
-BDEPEND="
- test? (
- $(python_gen_cond_dep '
- dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
- ' 3.8)
- )
-"
distutils_enable_tests pytest
diff --git a/dev-python/time-machine/time-machine-2.9.0.ebuild b/dev-python/time-machine/time-machine-2.9.0.ebuild
index 6c033cf82850..0f892d6ef9fc 100644
--- a/dev-python/time-machine/time-machine-2.9.0.ebuild
+++ b/dev-python/time-machine/time-machine-2.9.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
@@ -25,12 +25,5 @@ KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv"
RDEPEND="
dev-python/python-dateutil[${PYTHON_USEDEP}]
"
-BDEPEND="
- test? (
- $(python_gen_cond_dep '
- dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
- ' 3.8)
- )
-"
distutils_enable_tests pytest