summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-01 07:38:21 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-01 07:38:21 +0100
commitde3dceec7fd6ea79d60446d6902230a0d5d7a0dd (patch)
tree5166b38d878ee5ff82079740e4c5e313c11321ec /dev-python/time-machine
parentdev-python/hatchling: Bump to 1.12.1 (diff)
downloadgentoo-de3dceec7fd6ea79d60446d6902230a0d5d7a0dd.tar.gz
gentoo-de3dceec7fd6ea79d60446d6902230a0d5d7a0dd.tar.bz2
gentoo-de3dceec7fd6ea79d60446d6902230a0d5d7a0dd.zip
dev-python/time-machine: Bump to 2.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/time-machine')
-rw-r--r--dev-python/time-machine/Manifest1
-rw-r--r--dev-python/time-machine/time-machine-2.9.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/time-machine/Manifest b/dev-python/time-machine/Manifest
index a8fc15ce2551..a418d0444381 100644
--- a/dev-python/time-machine/Manifest
+++ b/dev-python/time-machine/Manifest
@@ -1 +1,2 @@
DIST time-machine-2.8.2.gh.tar.gz 27856 BLAKE2B 2669bacfc7fb9d10186d6053ee155ca7dd28ec3da688971baa371eb8e095a8694e955797bdf1b556056e79277d46c2382dd06979d8e960da5731c3710018e445 SHA512 f49442fe2b846676abca15a9e7231a4b59e8d520482a4ef2294eac9a4e2c0866836d6bd9bec42202bf5f9e94766e9c2a00d4f7c6eb76d5cbc8a702fceef4294c
+DIST time-machine-2.9.0.gh.tar.gz 28043 BLAKE2B 9a9a521c94b72a7464853661da791b6f57f5155ddc62ffceeb82f808903f4c337e6bf48fe8300bb4f9f5673fd175fd85038a4e80a39e8f3e096c12c27ee790ec SHA512 ecc780a72d279b49d026a8f3f89210cb4c90e02c5a517c08eadbabcb65216a24c603ace39afd76ea1e6ccdef589d5997581d0db7477bb28fe4d1e0510daf17a0
diff --git a/dev-python/time-machine/time-machine-2.9.0.ebuild b/dev-python/time-machine/time-machine-2.9.0.ebuild
new file mode 100644
index 000000000000..a526c33dc380
--- /dev/null
+++ b/dev-python/time-machine/time-machine-2.9.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Travel through time in your tests"
+HOMEPAGE="
+ https://github.com/adamchainz/time-machine/
+ https://pypi.org/project/time-machine/
+"
+SRC_URI="
+ https://github.com/adamchainz/time-machine/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
+ ' 3.8)
+ )
+"
+
+distutils_enable_tests pytest