summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-06 21:37:32 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-06 21:48:57 +0100
commit04e0bba6292cce136ae69d1799d6ba5f91faafe6 (patch)
treed6aea2bef410ef555fb62f634fb0768fa6bade16 /dev-python/tomli-w
parentdev-python/proto-plus: Bump to 1.19.7 (diff)
downloadgentoo-04e0bba6292cce136ae69d1799d6ba5f91faafe6.tar.gz
gentoo-04e0bba6292cce136ae69d1799d6ba5f91faafe6.tar.bz2
gentoo-04e0bba6292cce136ae69d1799d6ba5f91faafe6.zip
dev-python/tomli-w: Bump to 0.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tomli-w')
-rw-r--r--dev-python/tomli-w/Manifest1
-rw-r--r--dev-python/tomli-w/metadata.xml2
-rw-r--r--dev-python/tomli-w/tomli-w-0.4.0.ebuild26
3 files changed, 28 insertions, 1 deletions
diff --git a/dev-python/tomli-w/Manifest b/dev-python/tomli-w/Manifest
index d51775295d71..fe492e2f4aa0 100644
--- a/dev-python/tomli-w/Manifest
+++ b/dev-python/tomli-w/Manifest
@@ -1 +1,2 @@
DIST tomli-w-0.3.0.gh.tar.gz 61366 BLAKE2B 1ca3d50237d41fb22e8d506d2d8af3c5d9f690161a44439d3a79038bda7a67a6af9ad62b077169b5c2bdaee2110a3be5e3eec652aa8866a20c5841662f18a7e1 SHA512 618b93f2d98eee4fafe502e25f8770dc58558b25d9ec548fa5d0a6bdd8914e487fb1d16b68d138e0f8a48a6e5713c23e4d1a6daf70c8eafa27630fee05dfe8df
+DIST tomli-w-0.4.0.gh.tar.gz 63717 BLAKE2B 13f73718e84602e65243708481c546379120741bdef2c9b5dd53fc0a8f81bb098acfc18d8623d3b4ad9fe0ac37594c3c0fee94e009428cde2b46b6819f5598d1 SHA512 0a3940fd738aa62c9409cf33c515c33e232796374c10a7d0b0a7fcaf2d39e846cc1cf87700b5e8d5601e4bd02e76f5ee322c9d5fb37d4706670d34d8313fd19d
diff --git a/dev-python/tomli-w/metadata.xml b/dev-python/tomli-w/metadata.xml
index 499f307591cc..7a20d261085f 100644
--- a/dev-python/tomli-w/metadata.xml
+++ b/dev-python/tomli-w/metadata.xml
@@ -7,6 +7,6 @@
<stabilize-allarches/>
<upstream>
<remote-id type="github">hukkin/tomli-w</remote-id>
- <remote-id type="pypi">tomli_w</remote-id>
+ <remote-id type="pypi">tomli-w</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/tomli-w/tomli-w-0.4.0.ebuild b/dev-python/tomli-w/tomli-w-0.4.0.ebuild
new file mode 100644
index 000000000000..04615adae4a9
--- /dev/null
+++ b/dev-python/tomli-w/tomli-w-0.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A lil' TOML writer"
+HOMEPAGE="
+ https://pypi.org/project/tomli-w/
+ https://github.com/hukkin/tomli-w/"
+SRC_URI="
+ https://github.com/hukkin/tomli-w/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? ( dev-python/tomli[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest