summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-03 09:32:43 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-03 09:35:19 +0100
commit24444ffe4153c4f29c01056888d5c0b3bc176a32 (patch)
tree37d4ce1e75b1785affac8a615a1d9b5a51141a4d /dev-python/traitlets
parentdev-python/netaddr: Bump to 0.10.1 (diff)
downloadgentoo-24444ffe4153c4f29c01056888d5c0b3bc176a32.tar.gz
gentoo-24444ffe4153c4f29c01056888d5c0b3bc176a32.tar.bz2
gentoo-24444ffe4153c4f29c01056888d5c0b3bc176a32.zip
dev-python/traitlets: Bump to 5.14.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/traitlets')
-rw-r--r--dev-python/traitlets/Manifest1
-rw-r--r--dev-python/traitlets/traitlets-5.14.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/traitlets/Manifest b/dev-python/traitlets/Manifest
index 14208cfbef7e..298fb584ddf0 100644
--- a/dev-python/traitlets/Manifest
+++ b/dev-python/traitlets/Manifest
@@ -1 +1,2 @@
DIST traitlets-5.14.0.tar.gz 160561 BLAKE2B cca468f0566daf08517c45a7821dcef2727bf1d67dba3265c298da6bd7d86bf93f72e0c46f2518c2b07eeaa0900986c09256f7a858646175dc1c9289e0621894 SHA512 d0526bf137061709a3c5402dd0be59391cfbd39469d78784f7cbd94fb2150294b5c2b24d100c9eec64c63e42f9c53ebf334fd0222f6bf6426676ca9b811b41f5
+DIST traitlets-5.14.1.tar.gz 161107 BLAKE2B b247ce64383a6d677e426668cab844b8c476bd3bfaa6a1aa4d8325dd53c5c507aaa80b482e172771c491fea44de1568ca8455679a5fc915046d1d2bdba3b44d7 SHA512 c71f6a7825650eaf57d832e13c45b2526233082f371ab8ee035181c089558a11dc8ef4923b87a96cfdb80e83ba05d70d997686c031bde94c6bd523e032ba68fb
diff --git a/dev-python/traitlets/traitlets-5.14.1.ebuild b/dev-python/traitlets/traitlets-5.14.1.ebuild
new file mode 100644
index 000000000000..9247ee0cd585
--- /dev/null
+++ b/dev-python/traitlets/traitlets-5.14.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A configuration system for Python applications"
+HOMEPAGE="
+ https://github.com/ipython/traitlets/
+ https://pypi.org/project/traitlets/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+BDEPEND="
+ test? (
+ >=dev-python/argcomplete-2.0[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ dev-python/myst-parser \
+ dev-python/pydata-sphinx-theme
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ tests/test_typing.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_mock
+}