summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-17 07:53:02 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-17 08:54:25 +0200
commit98c2b4a3c73ea8215e749953023a9cfa8959d03b (patch)
tree5aae932f0a7e4352164e4adeb3a44a82d67eba97 /dev-python/traitlets
parentdev-python/terminado: Bump to 0.15.0 (diff)
downloadgentoo-98c2b4a3c73ea8215e749953023a9cfa8959d03b.tar.gz
gentoo-98c2b4a3c73ea8215e749953023a9cfa8959d03b.tar.bz2
gentoo-98c2b4a3c73ea8215e749953023a9cfa8959d03b.zip
dev-python/traitlets: Bump to 5.2.1_p0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/traitlets')
-rw-r--r--dev-python/traitlets/Manifest1
-rw-r--r--dev-python/traitlets/traitlets-5.2.1_p0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/traitlets/Manifest b/dev-python/traitlets/Manifest
index cb1e0055daeb..6fe999fb015a 100644
--- a/dev-python/traitlets/Manifest
+++ b/dev-python/traitlets/Manifest
@@ -1,2 +1,3 @@
DIST traitlets-5.1.1.tar.gz 130629 BLAKE2B 75a6f11d95e3989b9faffd576a1c9c45aa413b0b8c6ac853368902a60aad735ffd9699e721878af4e449d07ca6c2b0fae584fa2ae17707408ea9ca7591d38f75 SHA512 6ef5fcde81e1403b4b28c80e636c75f49819e319863dfa654aa5bbb96d18cca82ef8e7878cc8cccdb988d75201c3912fc49c31b673d7182a1f7d3cc78c115112
DIST traitlets-5.2.0.tar.gz 97379 BLAKE2B af0d3b45803c7318139cc2efe2308db1c0c1ddbec9bcecf328db62681a168f924a21d2495e1ff8d8ea5aca2aad9fcd34f7f961b5a6937f2cbefb4b00f4eb7d67 SHA512 d052c00e6dcb83a056a015f49244230ecd82d9cbcb7ea7cee4f543229fe725cfb80d1b8d055ec5a466b8d16a5f42e6a7aa962f0f12d3f47b9d2edf2a1590aa84
+DIST traitlets-5.2.1.post0.tar.gz 136620 BLAKE2B 41b1f1310a52e42b5c4d41aca1bf46125d7b185d81898887f4d4c8e9164b6947ad13a3b8fd7c07bccc88f8deb1e6f5043519c807f0eb14ab9eb24801bef9c846 SHA512 001b1e62bf622334b086bfd49f62a724d1c171b134f0503638e0a96b043478799b97b8e4689d8a30f1a92d65914915f45c2b2bfc8236feb0cb8634fbb5a8f6f0
diff --git a/dev-python/traitlets/traitlets-5.2.1_p0.ebuild b/dev-python/traitlets/traitlets-5.2.1_p0.ebuild
new file mode 100644
index 000000000000..2a9801310e91
--- /dev/null
+++ b/dev-python/traitlets/traitlets-5.2.1_p0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="A configuration system for Python applications"
+HOMEPAGE="
+ https://github.com/ipython/traitlets/
+ https://pypi.org/project/traitlets/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_sphinx docs/source \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}