summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-29 10:30:43 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-29 10:34:47 +0200
commit6e8261a0f62e4254aaeea3ab255e595adf66f9d7 (patch)
treea91a434769cb7ce30d2a1b4b05906a53dd6e5e96 /dev-python/traitsui
parentdev-python/apptools: Version Bump (diff)
downloadgentoo-6e8261a0f62e4254aaeea3ab255e595adf66f9d7.tar.gz
gentoo-6e8261a0f62e4254aaeea3ab255e595adf66f9d7.tar.bz2
gentoo-6e8261a0f62e4254aaeea3ab255e595adf66f9d7.zip
dev-python/traitsui: Version Bump
Package-Manager: portage-2.2.22 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/traitsui')
-rw-r--r--dev-python/traitsui/Manifest1
-rw-r--r--dev-python/traitsui/traitsui-4.5.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/traitsui/Manifest b/dev-python/traitsui/Manifest
index 4ca126957012..8154cbcab255 100644
--- a/dev-python/traitsui/Manifest
+++ b/dev-python/traitsui/Manifest
@@ -1 +1,2 @@
DIST traitsui-4.4.0.tar.gz 598148 SHA256 68a10c4f86cf0f5ba5d9fac5caece73e0a76256a4175efcded5edec03949cf60 SHA512 bd563330aa80acbf4087b54f42ffb94856495cf82da8b9c5ae54bdcda2d2544e4293a427ed3b28de7622c2fe063cd14f969b894735eb81cb4932cc3e2ad27bef WHIRLPOOL f49f6278d1b9ec0cc35af5f5f8b695c34082fd3ae8acdc0990634b15305d09b5f975f8906e568ca8ca25a746822c1d11c0c2c7933ad429856ec614fad51c84b6
+DIST traitsui-4.5.1.tar.gz 6692940 SHA256 452bfe7ffb9e38948cacbcfc66cc922cec3a3cb415e5fa02ef0d756ea673104d SHA512 b329d79515752e74834ac31c10d20fb75286c8b1ceab4ec7e8cdb76db586d796dcd5aa038318915e828d6ac86428b60d1e21e94c37edc45e7cb4950305252291 WHIRLPOOL a05d109200cb99998d354812bec36d101179f3be269f29e9f750290d779be6e21317851490b81b2666af09280e5ab264f99a55fb38636cfbaf2d052495d31b84
diff --git a/dev-python/traitsui/traitsui-4.5.1.ebuild b/dev-python/traitsui/traitsui-4.5.1.ebuild
new file mode 100644
index 000000000000..569d9ac7e082
--- /dev/null
+++ b/dev-python/traitsui/traitsui-4.5.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Enthought Tool Suite: Traits-capable user interfaces"
+HOMEPAGE="https://github.com/enthought/traitsui"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples test"
+
+RDEPEND="
+ dev-python/pyface[${PYTHON_USEDEP}]
+ dev-python/traits[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ )"
+
+python_test() {
+ export ETS_TOOLKIT=qt4
+ export QT_API=pyqt
+ VIRTUALX_COMMAND="nosetests -v" virtualmake
+}
+
+python_install_all() {
+ use examples && EXAMPLES=( examples )
+ distutils-r1_python_install_all
+}