summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-08-03 20:49:35 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-08-03 20:49:35 +0200
commit2b354365f13ee0c70be337e5ec075718b0d08888 (patch)
treebb25dbbb27010a94817aed15bf037cbe9c62c450 /dev-python/transitions
parentdev-libs/libevdev: Version bump to 1.9.1 (diff)
downloadgentoo-2b354365f13ee0c70be337e5ec075718b0d08888.tar.gz
gentoo-2b354365f13ee0c70be337e5ec075718b0d08888.tar.bz2
gentoo-2b354365f13ee0c70be337e5ec075718b0d08888.zip
dev-python/transitions: bump to version 0.8.2
Closes: https://bugs.gentoo.org/733884 Closes: https://bugs.gentoo.org/732570 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-python/transitions')
-rw-r--r--dev-python/transitions/Manifest1
-rw-r--r--dev-python/transitions/transitions-0.8.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/transitions/Manifest b/dev-python/transitions/Manifest
index e98abd16b146..be8117671686 100644
--- a/dev-python/transitions/Manifest
+++ b/dev-python/transitions/Manifest
@@ -1,2 +1,3 @@
DIST transitions-0.7.1.tar.gz 1283833 BLAKE2B 5f2f2813ba158cf5ccac4e2d55700149b986bdd24f9e864cec8d03390724cf79d9d379afa06b1a7b56c6a91376410252fdda169024f6ebbba2ed976fe7a18e7b SHA512 3fe5989faf9dbfdc15d50beaf2656240317f00278727271e5bd64ad465be1640b67e760fb73f4b06a61920343215815a8be03d41dc4d32086222446463ef71d7
DIST transitions-0.8.1.tar.gz 1094152 BLAKE2B 38e687fd30ae5a49c4c5f4339fe31728c4f44539a8d977337b54015d939aa48e39616e2044b1f5a7f6d7f82b34f2a0e807c36b9d416e10fcb0cd04db4bb9f840 SHA512 627f4f26cc24b1ac2e43cd6570341620b32e1f75662d3bde069ba5f3547e2670380d6e58876f8208f0411c91d8d2c21e500e8c91565b3a8748e07d2f4d94b0f6
+DIST transitions-0.8.2.tar.gz 1084797 BLAKE2B 9ff6284e7c42365c5a169388057acffd53dd31c3ca6d9dee240b253ca34118a67d3f070fd8b6a86cb6a01a2e15023e0bad02ccc07813ee0855a54008ac3d7597 SHA512 d10e513806801d0c874be3eb59e92ad61584b5f7992ba26db8828848df1225fb806621abc118a8d43f2efaa353d988b5becbe4296bc054754e551c86495a540f
diff --git a/dev-python/transitions/transitions-0.8.2.ebuild b/dev-python/transitions/transitions-0.8.2.ebuild
new file mode 100644
index 000000000000..9256f6b345ca
--- /dev/null
+++ b/dev-python/transitions/transitions-0.8.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A lightweight, object-oriented state machine implementation in Python"
+HOMEPAGE="https://github.com/pytransitions/transitions"
+SRC_URI="https://github.com/pytransitions/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/graphviz[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/dill[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pycodestyle[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+
+ use examples && dodoc examples/*.ipynb
+}