summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-29 10:01:46 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-29 12:45:56 +0100
commiteea7adf3dac7d9d995b3a98900764f0993efec93 (patch)
tree6ad40f57892017cccec2fa7f08f6e84b0612ce39 /dev-python/transitions
parentxfce-extra/xfce4-panel-profiles: Bump to 1.0.12 (diff)
downloadgentoo-eea7adf3dac7d9d995b3a98900764f0993efec93.tar.gz
gentoo-eea7adf3dac7d9d995b3a98900764f0993efec93.tar.bz2
gentoo-eea7adf3dac7d9d995b3a98900764f0993efec93.zip
dev-python/transitions: Bump to 0.8.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/transitions')
-rw-r--r--dev-python/transitions/Manifest1
-rw-r--r--dev-python/transitions/transitions-0.8.6.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/transitions/Manifest b/dev-python/transitions/Manifest
index b7533d5d980c..1ede0c796f0d 100644
--- a/dev-python/transitions/Manifest
+++ b/dev-python/transitions/Manifest
@@ -1 +1,2 @@
DIST transitions-0.8.2.tar.gz 1084797 BLAKE2B 9ff6284e7c42365c5a169388057acffd53dd31c3ca6d9dee240b253ca34118a67d3f070fd8b6a86cb6a01a2e15023e0bad02ccc07813ee0855a54008ac3d7597 SHA512 d10e513806801d0c874be3eb59e92ad61584b5f7992ba26db8828848df1225fb806621abc118a8d43f2efaa353d988b5becbe4296bc054754e551c86495a540f
+DIST transitions-0.8.6.tar.gz 1092437 BLAKE2B 14a8f50bb3ab34e5a6589c1ccc14482373fcbe670d64cd822ef483da10d5e19771bea28ce26690907862422a7687cacccb8c82f5f623ba34888e88dbf2601945 SHA512 9ada9075074a1201c0858786ea446e5dd36576e154238dccbebc2523da0bd46cb676e7eb4abf1102207b2e674d3214dd4869b3c51a6b9e9799c38bd6be8aedac
diff --git a/dev-python/transitions/transitions-0.8.6.ebuild b/dev-python/transitions/transitions-0.8.6.ebuild
new file mode 100644
index 000000000000..cf203ef1f988
--- /dev/null
+++ b/dev-python/transitions/transitions-0.8.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="A lightweight, object-oriented state machine implementation in Python"
+HOMEPAGE="https://github.com/pytransitions/transitions"
+SRC_URI="https://github.com/pytransitions/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ || (
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ dev-python/graphviz[${PYTHON_USEDEP}]
+ )
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ test? (
+ dev-python/dill[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pycodestyle[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+
+ use examples && dodoc examples/*.ipynb
+}