summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-30 12:59:28 +0100
committerJustin Lecher <jlec@gentoo.org>2015-10-30 13:03:49 +0100
commite6a8aab73873581dc56d61c5c3fe07d460c2da4c (patch)
treeff1ad5c8c9279116e069f8e07270cd5291f854d9 /dev-python/twill/twill-0.9-r1.ebuild
parentapp-text/calibre: Move to virtual/dnspython (diff)
downloadgentoo-e6a8aab73873581dc56d61c5c3fe07d460c2da4c.tar.gz
gentoo-e6a8aab73873581dc56d61c5c3fe07d460c2da4c.tar.bz2
gentoo-e6a8aab73873581dc56d61c5c3fe07d460c2da4c.zip
dev-python/twill: Move to virtual/dnspython
QA: add missing die Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/twill/twill-0.9-r1.ebuild')
-rw-r--r--dev-python/twill/twill-0.9-r1.ebuild21
1 files changed, 14 insertions, 7 deletions
diff --git a/dev-python/twill/twill-0.9-r1.ebuild b/dev-python/twill/twill-0.9-r1.ebuild
index 1d397df7a63c..d69c8f747792 100644
--- a/dev-python/twill/twill-0.9-r1.ebuild
+++ b/dev-python/twill/twill-0.9-r1.ebuild
@@ -3,6 +3,7 @@
# $Id$
EAPI="5"
+
PYTHON_COMPAT=( python2_7 pypy )
inherit distutils-r1
@@ -19,18 +20,24 @@ SLOT="0"
KEYWORDS="amd64 ~arm ppc ~ppc64 x86"
IUSE="doc examples"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( $(python_gen_cond_dep 'dev-python/epydoc[${PYTHON_USEDEP}]' python2_7)
- $(python_gen_cond_dep 'dev-python/dnspython[${PYTHON_USEDEP}]' python2_7) )"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ $(python_gen_cond_dep 'dev-python/epydoc[${PYTHON_USEDEP}]' python2_7)
+ || (
+ dev-python/dnspython:0[${PYTHON_USEDEP}]
+ virtual/dnspython:0[${PYTHON_USEDEP}]
+ )
+ )"
S="${WORKDIR}/${MY_P}"
python_compile_all() {
if use doc; then
- pushd doc > /dev/null
- chmod +x make-epydoc.sh
- ./make-epydoc.sh
- popd> /dev/null
+ pushd doc > /dev/null || die
+ chmod +x make-epydoc.sh || die
+ ./make-epydoc.sh || die
+ popd> /dev/null || die
fi
}