summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-13 10:20:14 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-13 10:55:53 +0100
commit056dff0a3d6b60d354c1a5817229c78ab3da37d5 (patch)
treeab5ba499ce15023605fda98d4ea422b699318974 /dev-python/twython
parentpackage.mask: Recover dev-python/twython (diff)
downloadgentoo-056dff0a3d6b60d354c1a5817229c78ab3da37d5.tar.gz
gentoo-056dff0a3d6b60d354c1a5817229c78ab3da37d5.tar.bz2
gentoo-056dff0a3d6b60d354c1a5817229c78ab3da37d5.zip
dev-python/twython: Bump to 3.7.0, py3.{7,8}, tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/twython')
-rw-r--r--dev-python/twython/Manifest1
-rw-r--r--dev-python/twython/twython-3.7.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/twython/Manifest b/dev-python/twython/Manifest
index b0ff30e9fff6..63e66fd13769 100644
--- a/dev-python/twython/Manifest
+++ b/dev-python/twython/Manifest
@@ -1,2 +1,3 @@
DIST twython-3.3.0.tar.gz 34164 BLAKE2B 82320b4fc787c97a3b1f773fdd3d5c0c636e6062eb630cc7d78625f45fb8478789e4acc3c9a7ebf600d7abb591bb6113e167a11eaa7b6afebb419652f1d9833f SHA512 888f37c37f39c603b08605d2e209afc329e079c405adbe3a03fde4dab2b76b07d2badf1956d255d4b7ff0bf2a4c308b20f2a3333a7ccd0e7b9c046e9172b1d5f
DIST twython-3.6.0.tar.gz 36268 BLAKE2B 24305d2221cf7856f5e51bc3ec0fb4c342a8ce19c248ccc680bb1847e20a262f15399b4fe904852a159fc83a85d5617bd57c3ea9de064a5a25069175ae02178d SHA512 b99ecb244598a489578e63cec8a470daca7efe019f6a5277a0fda70b3c61ba25b56688b0a383337ed1c46576e551c244da82cd808710c4b9bb8ba91c6bc29be1
+DIST twython-3.7.0.gh.tar.gz 373183 BLAKE2B a84e10c1d61736af3e93f265d92104dac15d5f7a43d7fbdce4e8c58b641f671a1c4c10f44c5b6d6ce9f0646860d35c14414b17e84daeb74f6e2c8871207b6fd4 SHA512 33eb35ea811ec1964fcd51fad54ba53d60e6caf3b5b7d11ae138f7228be9fb1eca7a02b1c6699a62cc2f6c39e035cb5a28f53ef67a98d019cdf91c9874867871
diff --git a/dev-python/twython/twython-3.7.0.ebuild b/dev-python/twython/twython-3.7.0.ebuild
new file mode 100644
index 000000000000..78ec75b623aa
--- /dev/null
+++ b/dev-python/twython/twython-3.7.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="An easy way to access Twitter data with Python"
+HOMEPAGE="https://github.com/ryanmcgrath/twython"
+SRC_URI="https://github.com/ryanmcgrath/twython/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/requests-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.4.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( dev-python/responses[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # tests are largely broken/outdated
+ sed -e 's:test_get_lastfunction_header_should_return_header:_&:' \
+ -e 's:test_request_should_handle_4:_&:' \
+ -e 's:test_request_should_handle_rate_limit:_&:' \
+ -i tests/test_core.py || die
+
+ distutils-r1_src_prepare
+}