summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-08-01 18:34:27 +0000
committerBrian Dolbec <dolsen@gentoo.org>2017-08-01 18:51:23 +0000
commit9bb9990cb236dadec328b8094f05e26de1d17cf2 (patch)
tree339da7629a955508946c686a0ccd2b57922af452 /dev-python/txaio
parentdev-python/service_identity: Version bump (diff)
downloadgentoo-9bb9990cb236dadec328b8094f05e26de1d17cf2.tar.gz
gentoo-9bb9990cb236dadec328b8094f05e26de1d17cf2.tar.bz2
gentoo-9bb9990cb236dadec328b8094f05e26de1d17cf2.zip
dev-python/txaio: Version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-python/txaio')
-rw-r--r--dev-python/txaio/Manifest1
-rw-r--r--dev-python/txaio/txaio-2.8.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/txaio/Manifest b/dev-python/txaio/Manifest
index 89eba1b96d8f..1f1e90d55468 100644
--- a/dev-python/txaio/Manifest
+++ b/dev-python/txaio/Manifest
@@ -1,3 +1,4 @@
DIST txaio-2.3.1.tar.gz 36755 SHA256 1111c87bff73e22c2067318cbb267781e2f651c485d21783b25e1e768eabab67 SHA512 019d686102c862ec308e8ffdfbca25cda1b495adef73ee8b817a465a8054a24590ab0f1e3322df92d0a528152fc5b987b98b039dcd87308e81854d3c6a9fb146 WHIRLPOOL c5f550788f669237d24c5194348a84f5e6e8ca5206bd647ff8e5dee80705809601b798c4eecca260defa69d3276c77adbee6599529b48a325ec7865902c77d89
DIST txaio-2.5.1.tar.gz 41577 SHA256 625076477182e2dde78b79d0b2b0d6b3cecb0e24fe0ea7eaf2abd26a4c0dd1de SHA512 921b4f6738a91923cffe00eed30237e0a2a12dbd42476587b4902675d3d7d8ecbf3b6fbf47afa5648836f779f1c22f7edf9bd94d44dcacee86d03a1dd16450a5 WHIRLPOOL 24286b510c7f1911dd2a315362c76aff77bc2246164a4a1ba50573d87408db9e0e384e5063cfdbee96501b3d03decc9f4198aae9f8cd375d8c49de817d0eda63
DIST txaio-2.7.1.tar.gz 43591 SHA256 9eea85c27ff8ac28049a29b55383f5c162351f855860e5081ff4632d65a5b4d2 SHA512 d77a8b5e8fc21be0bef43f2a6795229456a351abc1a5eb6d2b7de0da0a58e67a228cb06d1a7962efcc760099ef5df94e9421875ea5628985260911efc7deb85e WHIRLPOOL 2acff5b81fd17afd7b7d986812d742a6e09781f8f6f960ae6c08a52c6535156736492ecaca0c8026192289ab28e3cceb40e03aa4512922bc64ece7c900abd25c
+DIST txaio-2.8.1.tar.gz 43558 SHA256 fe2e0e4d3a06705f86bbd351fdd1f39dae61755e44162375e024acbf32eafddb SHA512 5ea41dbc8fef6dcd04a95c85bd57c4f2fd57f7091667da8a822a0e8bad465f76c2ace574e4ae54f941ad6e169dce6fb28d752831d7a06eb240ef72cc3817a056 WHIRLPOOL 5fec7bba468b52bf3ba13328d7e5f00a28eb487e238880d5afbf79bd6d8a017f39e2aa907c095a8c0fe28c41b2c917f4f72f8ad0f59ad241f329ca91a1f6961f
diff --git a/dev-python/txaio/txaio-2.8.1.ebuild b/dev-python/txaio/txaio-2.8.1.ebuild
new file mode 100644
index 000000000000..e34fed0bca3a
--- /dev/null
+++ b/dev-python/txaio/txaio-2.8.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Compatibility API between asyncio/Twisted/Trollius"
+HOMEPAGE="https://github.com/crossbario/txaio https://pypi.python.org/pypi/txaio"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ $(python_gen_cond_dep '>=dev-python/trollius-2.0[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep '>=dev-python/futures-3.0.3[${PYTHON_USEDEP}]' python2_7)
+"
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/sphinx-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/sphinxcontrib-spelling-2.1.2[${PYTHON_USEDEP}]
+ >=dev-python/sphinx_rtd_theme-0.1.9[${PYTHON_USEDEP}]
+ dev-python/alabaster[${PYTHON_USEDEP}]
+ )
+ test? ( >=dev-python/pytest-2.6.4[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-1.8.1[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/tox-2.1.1[${PYTHON_USEDEP}]
+ >=dev-python/pep8-1.6.2[${PYTHON_USEDEP}]
+ >=dev-python/pyenchant-1.6.6[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ default_src_prepare
+ # Take out failing tests known to pass when run manually
+ # we certainly don't need to test "python setup.py sdist" here
+ rm "${S}/test/test_packaging.py" || die
+}
+
+python_prepare() {
+ # https://github.com/tavendo/txaio/issues/3
+ cp -r "${FILESDIR}"/util.py test || die
+
+ distutils-r1_python_prepare
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}