summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-03-02 17:52:31 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-03-02 17:52:47 +0100
commita063c35d99ca49c5eccca5584657ee9d9410c16f (patch)
tree1c335e8e4be5d2ed4fe8738ea39044f3855a78cf /dev-python/txaio
parentdev-python/flask-migrate: Bump (diff)
downloadgentoo-a063c35d99ca49c5eccca5584657ee9d9410c16f.tar.gz
gentoo-a063c35d99ca49c5eccca5584657ee9d9410c16f.tar.bz2
gentoo-a063c35d99ca49c5eccca5584657ee9d9410c16f.zip
dev-python/txaio: Bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/txaio')
-rw-r--r--dev-python/txaio/Manifest1
-rw-r--r--dev-python/txaio/txaio-2.2.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/txaio/Manifest b/dev-python/txaio/Manifest
index 570690ee3a14..2edb0b0090b3 100644
--- a/dev-python/txaio/Manifest
+++ b/dev-python/txaio/Manifest
@@ -1,2 +1,3 @@
DIST txaio-1.0.0.zip 33656 SHA256 4b38afc5d416b23426ed4e7f582d949317df5173c50efec999f2cc97ed368a57 SHA512 7ca543721139e3da96e86d3d2feafbd0901df7a48585f43f46407a17c226e24bbd18841c50bf911c3f208d614c9e32bfc0a7bee37b03b9ddea87a8a47e940572 WHIRLPOOL d11ea36f27d26566a5dcce83751a723ac2e33c51ecc7019b95d66014850e94fc820ae44b36cbbe3c5a3f5b86de666a2b59cec29194ca3d4b9d39908bb47b2556
DIST txaio-2.2.0.tar.gz 33225 SHA256 5aa536f69d7a52bfe528863e783f20a70138269ed97d134222fdab6afa0dfe14 SHA512 13c4345fa0e64e86cecfa56e3cfa02ed088eed37dee582cc62b35b9e0984041a458ee837cdcb4ae56966e102f504b0cce8750d5ba8240c83815ca076d2deb979 WHIRLPOOL e75c5fc76f294d17e156b58fe69bb4719bc36a3966367b5e930bb9fef8e026d9a107ea0d883e1f7be569f4dfd0d85b472500a87c51fc012987c80f6d9352e774
+DIST txaio-2.2.1.tar.gz 35208 SHA256 6eee00c397d8193d15313dfc36da3eac8d64edf0b92fe3b67cd5a735ffc3074b SHA512 63a1d1a5807efc6b46821f77448c5b82cc5f2aca0b2e374c9c35baedee84903d400939698578d15428c4b1d2ad0471f5c7b17a6c815d020e4df8b4a85d787671 WHIRLPOOL 2edc46918e8f6ff7b6cd7282897a81e8dd31089bb6da722c5718e7cddd719dfb296231876222e0678f0eb570b12c83cd011acdbd9b027c7a8004e4beff6a46c9
diff --git a/dev-python/txaio/txaio-2.2.1.ebuild b/dev-python/txaio/txaio-2.2.1.ebuild
new file mode 100644
index 000000000000..ebf436d31040
--- /dev/null
+++ b/dev-python/txaio/txaio-2.2.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+RESTRICT="test"
+
+inherit distutils-r1
+
+DESCRIPTION="a helper library for writing code unmodified on both Twisted and asyncio"
+HOMEPAGE="https://github.com/tavendo/txaio"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/pep8-1.6.2[${PYTHON_USEDEP}]"
+
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/alabaster[${PYTHON_USEDEP}] )
+ test? ( >=dev-python/pytest-2.6.4[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-1.8.1[${PYTHON_USEDEP}] )"
+
+python_prepare() {
+ # https://github.com/tavendo/txaio/issues/3
+ cp -r "${FILESDIR}"/util.py test || die
+
+ distutils-r1_python_prepare
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}