summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-20 23:37:56 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-20 23:39:15 +0100
commitad7dee7c48fd2a9b0496d9e96f24d5d51f100ae6 (patch)
tree4a80a72a6643e38162f72c0be9c5e66c0a0bb710 /dev-python/ubelt/ubelt-1.0.1.ebuild
parentgames-fps/final-doom-data-gog: New package (diff)
downloadgentoo-ad7dee7c48fd2a9b0496d9e96f24d5d51f100ae6.tar.gz
gentoo-ad7dee7c48fd2a9b0496d9e96f24d5d51f100ae6.tar.bz2
gentoo-ad7dee7c48fd2a9b0496d9e96f24d5d51f100ae6.zip
dev-python/ubelt: Bump to 1.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ubelt/ubelt-1.0.1.ebuild')
-rw-r--r--dev-python/ubelt/ubelt-1.0.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/ubelt/ubelt-1.0.1.ebuild b/dev-python/ubelt/ubelt-1.0.1.ebuild
new file mode 100644
index 000000000000..0e9c2987b85a
--- /dev/null
+++ b/dev-python/ubelt/ubelt-1.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A stdlib like feel, and extra batteries. Hashing, Caching, Timing, Progress"
+HOMEPAGE="https://github.com/Erotemic/ubelt"
+SRC_URI="https://github.com/Erotemic/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="test? ( dev-python/xdoctest[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # relies on passwd home being equal to ${HOME}
+ ubelt/util_path.py::userhome:0
+)