summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-19 09:35:32 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-19 10:02:58 +0100
commit680615f98b1fc56d9ae5472022fa9fee51bf5125 (patch)
tree00362e1ce2a9450350d933fb3b6083bea2425a31 /dev-python/ukkonen
parentdev-python/hypothesis: Bump to 6.25.0 (diff)
downloadgentoo-680615f98b1fc56d9ae5472022fa9fee51bf5125.tar.gz
gentoo-680615f98b1fc56d9ae5472022fa9fee51bf5125.tar.bz2
gentoo-680615f98b1fc56d9ae5472022fa9fee51bf5125.zip
dev-python/ukkonen: New dep of dev-python/identify, v1.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ukkonen')
-rw-r--r--dev-python/ukkonen/Manifest1
-rw-r--r--dev-python/ukkonen/metadata.xml11
-rw-r--r--dev-python/ukkonen/ukkonen-1.0.0.ebuild27
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/ukkonen/Manifest b/dev-python/ukkonen/Manifest
new file mode 100644
index 000000000000..dbc7baf73229
--- /dev/null
+++ b/dev-python/ukkonen/Manifest
@@ -0,0 +1 @@
+DIST ukkonen-1.0.0.gh.tar.gz 4541 BLAKE2B c93623523fc57b27bb68a2bb41fca51a967910c4936140bee628b4270e343e7902b9e7a6fb85bc89c197e2b0c6897c2d3f788886541bc8b6b7758a6f158a5c6c SHA512 87e3078e8cd4807af3f91c1be7766454705b077cb093eadac34d1af4d56b458813c1062eb086232bffa43b5ca7aa07ed88192e56dacce96c6781f16129111d79
diff --git a/dev-python/ukkonen/metadata.xml b/dev-python/ukkonen/metadata.xml
new file mode 100644
index 000000000000..d4ba35cb5b1c
--- /dev/null
+++ b/dev-python/ukkonen/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">ukkonen</remote-id>
+ <remote-id type="github">asottile/ukkonen</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/ukkonen/ukkonen-1.0.0.ebuild b/dev-python/ukkonen/ukkonen-1.0.0.ebuild
new file mode 100644
index 000000000000..9b905245dcd3
--- /dev/null
+++ b/dev-python/ukkonen/ukkonen-1.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Implementation of bounded Levenshtein distance (Ukkonen)"
+HOMEPAGE="
+ https://pypi.org/project/ukkonen/
+ https://github.com/asottile/ukkonen/"
+SRC_URI="
+ https://github.com/asottile/ukkonen/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')"
+BDEPEND=${RDEPEND}
+
+distutils_enable_tests pytest