summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-16 13:21:14 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-16 13:21:41 +0100
commit2bbaaafe074a0a5806ebb51bc84eeed29af4d110 (patch)
tree62e38f7a9fbe6e847bfd5ab544e98c4ad490bd03 /dev-python/unittest-or-fail
parentnet-analyzer/ssldump: add json-c dep (diff)
downloadgentoo-2bbaaafe074a0a5806ebb51bc84eeed29af4d110.tar.gz
gentoo-2bbaaafe074a0a5806ebb51bc84eeed29af4d110.tar.bz2
gentoo-2bbaaafe074a0a5806ebb51bc84eeed29af4d110.zip
dev-python/unittest-or-fail: Bump to v1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/unittest-or-fail')
-rw-r--r--dev-python/unittest-or-fail/Manifest1
-rw-r--r--dev-python/unittest-or-fail/unittest-or-fail-1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/unittest-or-fail/Manifest b/dev-python/unittest-or-fail/Manifest
index 8ce67bb37efb..c0403e127ebd 100644
--- a/dev-python/unittest-or-fail/Manifest
+++ b/dev-python/unittest-or-fail/Manifest
@@ -1 +1,2 @@
DIST unittest-or-fail-0.tar.gz 2445 BLAKE2B 42d97fb3bd7e825ecf521ebbb435ca3973f83e107d86848f2c03d6d2321c9b87ec68db159e658bd5eead5321b7085ecec5350947818f55141eb18eb72719e2ad SHA512 8df21f5e235e03f4b5a8ae351420ac667612afddeb52a27bb2d4812bedbea87ba857dedfa37001a72872529b7c1984d15ddda93edfa6f989f0990b72c4b57baf
+DIST unittest-or-fail-1.tar.gz 2739 BLAKE2B 781fff33d12e2ebbf408875d8677a73fe3d5025c6d7e5e67ce23e1f5a36479e7680ffafc9ec73830a70114ddb8bb0c784095f15e8ee13fcf95fe4712c2d8a080 SHA512 c58a2b6a3723d1327d74fb528a5742f576a70453c81bcd55b551a6eac05bb6af4555b9274ca939df70ada85a0be42edd258ea7644ab1d24fbf897a1e96b23055
diff --git a/dev-python/unittest-or-fail/unittest-or-fail-1.ebuild b/dev-python/unittest-or-fail/unittest-or-fail-1.ebuild
new file mode 100644
index 000000000000..707e0b2b5bb7
--- /dev/null
+++ b/dev-python/unittest-or-fail/unittest-or-fail-1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Run unittests or fail if no tests were found"
+HOMEPAGE="https://github.com/mgorny/unittest-or-fail/"
+SRC_URI="
+ https://github.com/mgorny/unittest-or-fail/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# Warning: do not use distutils_enable_tests to avoid a circular
+# dependency on itself!
+python_test() {
+ "${EPYTHON}" -m unittest -v test/test_unittest_or_fail.py ||
+ die "Tests failed with ${EPYTHON}"
+}