summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-11 12:46:58 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-11 13:24:29 +0200
commited6b02c6d17ea15bb98027262f6bb6b76514760e (patch)
tree7a7a7b503aa696fee35789c062bbd5d0b82550b2 /dev-python/unittest2
parentdev-python/pytest: Add python3.5 support (diff)
downloadgentoo-ed6b02c6d17ea15bb98027262f6bb6b76514760e.tar.gz
gentoo-ed6b02c6d17ea15bb98027262f6bb6b76514760e.tar.bz2
gentoo-ed6b02c6d17ea15bb98027262f6bb6b76514760e.zip
dev-python/unittest2: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/unittest2')
-rw-r--r--dev-python/unittest2/unittest2-1.1.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/unittest2/unittest2-1.1.0-r1.ebuild b/dev-python/unittest2/unittest2-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..502d2ed886e8
--- /dev/null
+++ b/dev-python/unittest2/unittest2-1.1.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="The new features in unittest backported to Python 2.4+"
+HOMEPAGE="https://pypi.python.org/pypi/unittest2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/linecache2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4[${PYTHON_USEDEP}]
+ dev-python/traceback2[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}"
+
+PATCHES=( "${FILESDIR}"/remove-argparse-dependence.patch )
+
+python_test() {
+ "${PYTHON}" -m unittest2 discover || die "tests failed under ${EPYTHON}"
+}