summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD G Turner <digitall@scummvm.org>2020-09-26 14:07:21 +0100
committerSam James <sam@gentoo.org>2020-10-07 00:34:07 +0000
commit3b613c71f371e689ce74bf5e1e78244f0ef1761e (patch)
treedfaa20ea4212f6934b214f8eab90e7aed0327c37 /dev-python/uranium
parentdev-python/rtslib-fb: version bump to 2.1.74 (diff)
downloadgentoo-3b613c71f371e689ce74bf5e1e78244f0ef1761e.tar.gz
gentoo-3b613c71f371e689ce74bf5e1e78244f0ef1761e.tar.bz2
gentoo-3b613c71f371e689ce74bf5e1e78244f0ef1761e.zip
Revert "dev-python/uranium: remove unused patch(es)"
This reverts commit 9e3189e8fb3c13d834dedbbbce73df7b97b864fe. Removing these and the associated ebuild for v4.6.1 broke Cura v4.6.1 which was the most recent in the portage tree, but only at runtime. Signed-off-by: David G Turner <digitall@scummvm.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/uranium')
-rw-r--r--dev-python/uranium/files/uranium-4.6.1-fix-install-paths.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/uranium/files/uranium-4.6.1-fix-install-paths.patch b/dev-python/uranium/files/uranium-4.6.1-fix-install-paths.patch
new file mode 100644
index 000000000000..5777065e9da8
--- /dev/null
+++ b/dev-python/uranium/files/uranium-4.6.1-fix-install-paths.patch
@@ -0,0 +1,32 @@
+--- Uranium-4.5.0-orig/CMakeLists.txt 2020-03-01 16:26:44.736355687 +0200
++++ Uranium-4.5.0/CMakeLists.txt 2020-02-24 17:02:05.000000000 +0200
+@@ -12,6 +12,16 @@
+
+ find_package(PythonInterp 3.5.0 REQUIRED)
+
++if(NOT PYTHON_SITE_PACKAGES_DIR)
++ if(APPLE OR WIN32)
++ set(PYTHON_SITE_PACKAGES_DIR lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages
++ CACHE STRING "Directory to install Python bindings to")
++ else()
++ set(PYTHON_SITE_PACKAGES_DIR lib/python${PYTHON_VERSION_MAJOR}/dist-packages CACHE
++ STRING "Directory to install Python bindings to")
++ endif()
++endif()
++
+ # # Checks using pylint
+ # Note that we use exit 0 here to not mark the build as a failure on check failure
+ # In addition, the specified pylint configuration uses the spellchecker plugin. This required python-enchant to be installed.
+@@ -48,10 +58,10 @@
+ if(EXISTS /etc/debian_version)
+ install(DIRECTORY UM DESTINATION lib${LIB_SUFFIX}/python${PYTHON_VERSION_MAJOR}/dist-packages)
+ else()
+- install(DIRECTORY UM DESTINATION lib${LIB_SUFFIX}/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages)
++ install(DIRECTORY UM DESTINATION ${PYTHON_SITE_PACKAGES_DIR})
+ endif()
+ install(FILES ${CMAKE_SOURCE_DIR}/cmake/UraniumTranslationTools.cmake
+- DESTINATION ${CMAKE_INSTALL_DATADIR}/cmake-${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}/Modules/ )
++ DESTINATION ${CMAKE_INSTALL_DATADIR}/cmake/Modules/ )
+ install(DIRECTORY resources DESTINATION ${CMAKE_INSTALL_DATADIR}/uranium)
+
+ # Detect plugins to install