summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@omrb.pnpi.spb.ru>2018-06-14 16:05:32 +0300
committerAlexey Shvetsov <alexxy@omrb.pnpi.spb.ru>2018-06-14 16:05:32 +0300
commita8d750a27f38dead30108392b2194b49b7542271 (patch)
tree351e02cbd76f7ac834bb84d5255ace80656038a2 /dev-python/uranium
parentsci-libs/scipy: Version bump (diff)
downloadgentoo-a8d750a27f38dead30108392b2194b49b7542271.tar.gz
gentoo-a8d750a27f38dead30108392b2194b49b7542271.tar.bz2
gentoo-a8d750a27f38dead30108392b2194b49b7542271.zip
dev-python/uranium: Version bump and clean up
Closes: https://bugs.gentoo.org/630620 Closes: https://bugs.gentoo.org/648130 Closes: https://github.com/gentoo/gentoo/pull/8258 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/uranium')
-rw-r--r--dev-python/uranium/Manifest2
-rw-r--r--dev-python/uranium/files/uranium-2.3.1-fix-install-paths.patch30
-rw-r--r--dev-python/uranium/files/uranium-3.3.0-fix-install-paths.patch34
-rw-r--r--dev-python/uranium/uranium-3.3.0.ebuild (renamed from dev-python/uranium/uranium-2.6.0.ebuild)31
4 files changed, 53 insertions, 44 deletions
diff --git a/dev-python/uranium/Manifest b/dev-python/uranium/Manifest
index 52ee0a25a412..553789710350 100644
--- a/dev-python/uranium/Manifest
+++ b/dev-python/uranium/Manifest
@@ -1 +1 @@
-DIST uranium-2.6.0.tar.gz 826489 BLAKE2B c83a7276502b96c1e4ab942b55a99bedbb1edc615aad0a38dde94877e243c82977c21900a8c59561b7849ccd6917d1377c98cb533c4105306437d885b7dd73b2 SHA512 1c0b1381ffa213f7f1f7bfa86c31fd270d16506f672636f558be6c7bc375dcfe76f73fe2d0600caf055528a268372f91eead005c737348b774a78ee272a4650b
+DIST uranium-3.3.0.tar.gz 906093 BLAKE2B d41608170da64f93d6149e76cc28fa476e439f6b291bc667f8b562dbcde047f234aa77cfa52b73420f286b926ef05ef50df8fd74722fc81dd3fe94b407bee7f4 SHA512 48de8ecf100f6bfbaa6b3bc6562fef25991ad07375f3d8f752f130b44c2e4728b2979f99de23570cd46367d868bb7139dfd9d73a7d3755d2141edc1fd46939b3
diff --git a/dev-python/uranium/files/uranium-2.3.1-fix-install-paths.patch b/dev-python/uranium/files/uranium-2.3.1-fix-install-paths.patch
deleted file mode 100644
index a82484afd4f8..000000000000
--- a/dev-python/uranium/files/uranium-2.3.1-fix-install-paths.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff -urN Uranium-2.3.1.orig/CMakeLists.txt Uranium-2.3.1/CMakeLists.txt
---- Uranium-2.3.1.orig/CMakeLists.txt 2016-10-27 18:22:23.000000000 +0300
-+++ Uranium-2.3.1/CMakeLists.txt 2016-12-05 12:25:53.190933188 +0300
-@@ -43,14 +43,20 @@
- # Build Translations
- CREATE_TRANSLATION_TARGETS()
-
--if(APPLE OR WIN32)
-- install(DIRECTORY UM DESTINATION lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages)
--else()
-- install(DIRECTORY UM DESTINATION lib/python${PYTHON_VERSION_MAJOR}/dist-packages)
-+if(NOT PYTHON_SITE_PACKAGES_DIR)
-+ if(APPLE OR WIN32)
-+ set(PYTHON_SITE_PACKAGES_DIR lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages
-+ CACHE STRING "Directory to install Python bindings to")
-+ else()
-+ set(PYTHON_SITE_PACKAGES_DIR lib/python${PYTHON_VERSION_MAJOR}/dist-packages CACHE
-+ STRING "Directory to install Python bindings to")
-+ endif()
- endif()
-+
-+install(DIRECTORY UM DESTINATION ${PYTHON_SITE_PACKAGES_DIR})
- install(FILES ${CMAKE_SOURCE_DIR}/cmake/UraniumTranslationTools.cmake
-- DESTINATION ${CMAKE_INSTALL_DATADIR}/cmake-${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}/Modules/ )
-+ DESTINATION ${CMAKE_INSTALL_DATADIR}/cmake/Modules/ )
- install(DIRECTORY resources DESTINATION ${CMAKE_INSTALL_DATADIR}/uranium)
--install(DIRECTORY plugins DESTINATION lib/uranium)
-+install(DIRECTORY plugins DESTINATION ${CMAKE_INSTALL_LIBDIR}/uranium)
-
- include(CPackConfig.cmake)
diff --git a/dev-python/uranium/files/uranium-3.3.0-fix-install-paths.patch b/dev-python/uranium/files/uranium-3.3.0-fix-install-paths.patch
new file mode 100644
index 000000000000..598b93346a4f
--- /dev/null
+++ b/dev-python/uranium/files/uranium-3.3.0-fix-install-paths.patch
@@ -0,0 +1,34 @@
+--- Uranium-3.1.0-orig/CMakeLists.txt 2017-12-04 18:02:00.000000000 +0200
++++ Uranium-3.1.0/CMakeLists.txt 2017-12-29 18:57:22.493045527 +0200
+@@ -12,6 +12,16 @@
+
+ find_package(PythonInterp 3.5.0 REQUIRED)
+
++if(NOT PYTHON_SITE_PACKAGES_DIR)
++ if(APPLE OR WIN32)
++ set(PYTHON_SITE_PACKAGES_DIR lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages
++ CACHE STRING "Directory to install Python bindings to")
++ else()
++ set(PYTHON_SITE_PACKAGES_DIR lib/python${PYTHON_VERSION_MAJOR}/dist-packages CACHE
++ STRING "Directory to install Python bindings to")
++ endif()
++endif()
++
+ # # Checks using pylint
+ # Note that we use exit 0 here to not mark the build as a failure on check failure
+ # In addition, the specified pylint configuration uses the spellchecker plugin. This required python-enchant to be installed.
+@@ -48,11 +58,11 @@
+ if(EXISTS /etc/debian_version)
+ install(DIRECTORY UM DESTINATION lib${LIB_SUFFIX}/python${PYTHON_VERSION_MAJOR}/dist-packages)
+ else()
+- install(DIRECTORY UM DESTINATION lib${LIB_SUFFIX}/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages)
++ install(DIRECTORY UM DESTINATION ${PYTHON_SITE_PACKAGES_DIR})
+ endif()
+ install(FILES ${CMAKE_SOURCE_DIR}/cmake/UraniumTranslationTools.cmake
+- DESTINATION ${CMAKE_INSTALL_DATADIR}/cmake-${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}/Modules/ )
++ DESTINATION ${CMAKE_INSTALL_DATADIR}/cmake/Modules/ )
+ install(DIRECTORY resources DESTINATION ${CMAKE_INSTALL_DATADIR}/uranium)
+-install(DIRECTORY plugins DESTINATION lib${LIB_SUFFIX}/uranium)
++install(DIRECTORY plugins DESTINATION ${CMAKE_INSTALL_LIBDIR}/uranium)
+
+ include(CPackConfig.cmake)
diff --git a/dev-python/uranium/uranium-2.6.0.ebuild b/dev-python/uranium/uranium-3.3.0.ebuild
index 42085e598e26..fab0accebb6d 100644
--- a/dev-python/uranium/uranium-2.6.0.ebuild
+++ b/dev-python/uranium/uranium-3.3.0.ebuild
@@ -1,38 +1,43 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_COMPAT=( python3_{5,6} )
+
inherit cmake-utils python-single-r1
-MY_PN=Uranium
-MY_PV=${PV/_beta}
+MY_PN="Uranium"
DESCRIPTION="A Python framework for building 3D printing related applications"
HOMEPAGE="https://github.com/Ultimaker/Uranium"
-SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="AGPL-3+"
+LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
- ~dev-libs/libarcus-${PV}:*[${PYTHON_USEDEP}]
- dev-python/PyQt5[${PYTHON_USEDEP},declarative,network,svg]
+ dev-libs/libarcus:=[python,${PYTHON_USEDEP}]
+ <dev-python/PyQt5-5.10[${PYTHON_USEDEP},declarative,network,svg]
dev-python/numpy[${PYTHON_USEDEP}]
- dev-qt/qtdeclarative:5
- dev-qt/qtquickcontrols:5"
+ >=sci-libs/scipy-1.1[${PYTHON_USEDEP}]
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtquickcontrols2:5"
+
DEPEND="${RDEPEND}
sys-devel/gettext
doc? ( app-doc/doxygen )
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-S="${WORKDIR}/${MY_PN}-${MY_PV}"
-PATCHES=( "${FILESDIR}/${PN}-2.3.1-fix-install-paths.patch" )
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
DOCS=( README.md )
+PATCHES=( "${FILESDIR}/${PN}-3.3.0-fix-install-paths.patch" )
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
src_configure() {
local mycmakeargs=(
-DPYTHON_SITE_PACKAGES_DIR="$(python_get_sitedir)" )