summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2021-06-14 18:43:30 +0200
committerDennis Lamm <expeditioneer@gentoo.org>2021-06-14 19:02:09 +0200
commitbc3a2e833b6b718257978f0455c8fa69a4221cb4 (patch)
tree271f9dec46dcf7c635e6ee2e1e259d9bd5c74eaf /dev-python/uranium
parentx11-themes/numix-gtk-theme: fix src_install with high MAKEOPTS (diff)
downloadgentoo-bc3a2e833b6b718257978f0455c8fa69a4221cb4.tar.gz
gentoo-bc3a2e833b6b718257978f0455c8fa69a4221cb4.tar.bz2
gentoo-bc3a2e833b6b718257978f0455c8fa69a4221cb4.zip
dev-python/uranium-4.9.1: added missing dependency
Closes: https://bugs.gentoo.org/795273 Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/21238 Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'dev-python/uranium')
-rw-r--r--dev-python/uranium/uranium-4.9.1.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-python/uranium/uranium-4.9.1.ebuild b/dev-python/uranium/uranium-4.9.1.ebuild
index fa703e3b53ba..066a9e021074 100644
--- a/dev-python/uranium/uranium-4.9.1.ebuild
+++ b/dev-python/uranium/uranium-4.9.1.ebuild
@@ -26,6 +26,7 @@ BDEPEND="${PYTHON_DEPS}
$(python_gen_cond_dep '
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
')
)"
@@ -52,6 +53,10 @@ distutils_enable_tests pytest
src_prepare() {
python_fix_shebang .
+ if ! use doc ; then
+ sed -i -e '/add_custom_target(doc/d' CMakeLists.txt || die
+ fi
+
cmake_src_prepare
}