summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-16 22:06:13 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-16 22:09:43 +0100
commit5147284c7ee0be3bbf9cc72ef8a36b6f1f0ac4b3 (patch)
tree0a2f2b8040833308ab1549cf8e240669ef809670 /dev-python/urllib3
parentdev-python/pytest: Replace virts with cond deps (diff)
downloadgentoo-5147284c7ee0be3bbf9cc72ef8a36b6f1f0ac4b3.tar.gz
gentoo-5147284c7ee0be3bbf9cc72ef8a36b6f1f0ac4b3.tar.bz2
gentoo-5147284c7ee0be3bbf9cc72ef8a36b6f1f0ac4b3.zip
dev-python/urllib3: Replace virts with cond deps
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/urllib3')
-rw-r--r--dev-python/urllib3/urllib3-1.24.2.ebuild4
-rw-r--r--dev-python/urllib3/urllib3-1.25.7.ebuild4
-rw-r--r--dev-python/urllib3/urllib3-1.25.8.ebuild4
3 files changed, 9 insertions, 3 deletions
diff --git a/dev-python/urllib3/urllib3-1.24.2.ebuild b/dev-python/urllib3/urllib3-1.24.2.ebuild
index 5c781b4effa6..744dfd74e26d 100644
--- a/dev-python/urllib3/urllib3-1.24.2.ebuild
+++ b/dev-python/urllib3/urllib3-1.24.2.ebuild
@@ -25,7 +25,9 @@ RDEPEND="
>=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
>=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
>=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
- virtual/python-ipaddress[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/ipaddress[${PYTHON_USEDEP}]
+ ' -2)
"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
diff --git a/dev-python/urllib3/urllib3-1.25.7.ebuild b/dev-python/urllib3/urllib3-1.25.7.ebuild
index 7d7b50ac8af2..de5188583cf7 100644
--- a/dev-python/urllib3/urllib3-1.25.7.ebuild
+++ b/dev-python/urllib3/urllib3-1.25.7.ebuild
@@ -25,7 +25,9 @@ RDEPEND="
>=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
>=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
>=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
- virtual/python-ipaddress[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/ipaddress[${PYTHON_USEDEP}]
+ ' -2)
brotli? ( dev-python/brotlipy[${PYTHON_USEDEP}] )
"
BDEPEND="
diff --git a/dev-python/urllib3/urllib3-1.25.8.ebuild b/dev-python/urllib3/urllib3-1.25.8.ebuild
index 296a106fd7aa..4770e497d12f 100644
--- a/dev-python/urllib3/urllib3-1.25.8.ebuild
+++ b/dev-python/urllib3/urllib3-1.25.8.ebuild
@@ -25,7 +25,9 @@ RDEPEND="
>=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
>=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
>=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
- virtual/python-ipaddress[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/ipaddress[${PYTHON_USEDEP}]
+ ' -2)
brotli? ( dev-python/brotlipy[${PYTHON_USEDEP}] )
"
BDEPEND="