summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-20 11:27:26 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-20 11:36:29 +0200
commit558fe7a9d92b4c20350f37ba1e02fcc243b0455e (patch)
tree7c5a604b2142169f891db5118922807cd7c80eb9 /dev-python/utidylib/utidylib-0.6-r1.ebuild
parentpackage.mask: Last rite dev-python/subprocess32 (diff)
downloadgentoo-558fe7a9d92b4c20350f37ba1e02fcc243b0455e.tar.gz
gentoo-558fe7a9d92b4c20350f37ba1e02fcc243b0455e.tar.bz2
gentoo-558fe7a9d92b4c20350f37ba1e02fcc243b0455e.zip
dev-python/utidylib: Remove python2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/utidylib/utidylib-0.6-r1.ebuild')
-rw-r--r--dev-python/utidylib/utidylib-0.6-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/utidylib/utidylib-0.6-r1.ebuild b/dev-python/utidylib/utidylib-0.6-r1.ebuild
new file mode 100644
index 000000000000..65cb24ad7ccb
--- /dev/null
+++ b/dev-python/utidylib/utidylib-0.6-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+MY_P="uTidylib-${PV}"
+inherit distutils-r1
+
+DESCRIPTION="TidyLib Python wrapper"
+HOMEPAGE="https://cihar.com/software/utidylib/ https://pypi.org/project/uTidylib/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm64 ppc ppc64 x86"
+IUSE="doc test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ test? ( || ( $(python_gen_useflags 'python2*' python3_6 python3_7) ) )
+"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+DEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ app-text/tidy-html5
+"
+
+RESTRICT="test" # 1/11 tests fail
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}