summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-07 16:34:35 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-07 16:59:49 +0100
commit1eb55f8913bdfc726e941de7d8829dc546712ff4 (patch)
treee5d421f664ee9a07b8074dd91f0ebf5d7554e972 /dev-python/utidylib
parentdev-python/pyupgrade: Bump to 3.3.1 (diff)
downloadgentoo-1eb55f8913bdfc726e941de7d8829dc546712ff4.tar.gz
gentoo-1eb55f8913bdfc726e941de7d8829dc546712ff4.tar.bz2
gentoo-1eb55f8913bdfc726e941de7d8829dc546712ff4.zip
dev-python/utidylib: Bump to 0.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/utidylib')
-rw-r--r--dev-python/utidylib/Manifest1
-rw-r--r--dev-python/utidylib/utidylib-0.9.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/utidylib/Manifest b/dev-python/utidylib/Manifest
index d6764c451d75..66e38efbc0a0 100644
--- a/dev-python/utidylib/Manifest
+++ b/dev-python/utidylib/Manifest
@@ -1 +1,2 @@
DIST utidylib-0.8.gh.tar.gz 15285 BLAKE2B 85f0ec1a969f31cb952e326a5bce5f51d9a5bacdf33d7e703cc3a464621df86f568921a9dd17755be67d49c02631782cdabb4112ee7cf8e321079656bb362122 SHA512 cb9c868337e1bbfa80ac36ca1b3f85c4e35f62acb67dbd321167d568da17d9e562fdca6b777d88c08e03107401fbadc7cdebf243654bcde9825259117e36392f
+DIST utidylib-0.9.gh.tar.gz 15778 BLAKE2B 54c9b9b7c0615ac49a90567357f119643311dd6ee2848dcdfcbe00b93431672ee6954738627c0b3fa984a8f2c7b9e127cc1edac06f9760a252621317d2266476 SHA512 58ca8a43ba2e933f02111939ee8496bb63b17220ce5a6fa3cb731659e89000baa17409c10968308cd86bb2a9dc4819ef2029245eecdb3c7a3fa57404f37004fc
diff --git a/dev-python/utidylib/utidylib-0.9.ebuild b/dev-python/utidylib/utidylib-0.9.ebuild
new file mode 100644
index 000000000000..095b63b34c3a
--- /dev/null
+++ b/dev-python/utidylib/utidylib-0.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="TidyLib Python wrapper"
+HOMEPAGE="
+ https://cihar.com/software/utidylib/
+ https://github.com/nijel/utidylib/
+ https://pypi.org/project/uTidylib/
+"
+SRC_URI="
+ https://github.com/nijel/utidylib/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=app-text/htmltidy-5.0.0
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+EPYTEST_DESELECT=(
+ # https://github.com/nijel/utidylib/issues/9
+ tidy/test_tidy.py::TidyTestCase::test_missing_load
+)