summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-21 10:46:47 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-21 11:09:38 +0200
commit7372586f3e5dc5adcbacf227b388cfe3523201ba (patch)
treea6297d0e58f910ccd6a702852ca768b641b38948 /dev-python/utidylib
parentdev-python/virtualenv-clone: Bump to 0.5.7 (diff)
downloadgentoo-7372586f3e5dc5adcbacf227b388cfe3523201ba.tar.gz
gentoo-7372586f3e5dc5adcbacf227b388cfe3523201ba.tar.bz2
gentoo-7372586f3e5dc5adcbacf227b388cfe3523201ba.zip
dev-python/utidylib: Bump to 0.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/utidylib')
-rw-r--r--dev-python/utidylib/Manifest1
-rw-r--r--dev-python/utidylib/utidylib-0.8.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/utidylib/Manifest b/dev-python/utidylib/Manifest
index 04e26a3d08e7..cab22b729b09 100644
--- a/dev-python/utidylib/Manifest
+++ b/dev-python/utidylib/Manifest
@@ -1,2 +1,3 @@
DIST uTidylib-0.6.tar.gz 15771 BLAKE2B 9d4fe57d985ea6e52680bd528862d3236137221227a23fe05b886d01d240e21d7159dbf7d6da3af8020009ca45c60c2297e374bb7aa05cb6b5a8eaf444710c58 SHA512 a85506ef8824f66ee326ad651020dc3b4e00190e20dcd3814984fa27ff319f492fe5bac781b7c43c8694cbfc63409e3abda18981969c9be2c3cd023fe7a4f2f8
DIST utidylib-0.7.gh.tar.gz 15203 BLAKE2B c32f23ab3a94191423655f9b6a99bd85aca7072fcfea7507c5d4efb19c4ee22114afe136c6299e8322e15195c4f938094e49483b1a40d05522f2d232dd9a6acd SHA512 69b22671223cc9e1888a1be19b418e883baa79401bcf3856fa48cca441ae7fa414047c296f8fc9ff35aa7407901fa64cd8ddfcc56657a98e8e188073dfc72172
+DIST utidylib-0.8.gh.tar.gz 15285 BLAKE2B 85f0ec1a969f31cb952e326a5bce5f51d9a5bacdf33d7e703cc3a464621df86f568921a9dd17755be67d49c02631782cdabb4112ee7cf8e321079656bb362122 SHA512 cb9c868337e1bbfa80ac36ca1b3f85c4e35f62acb67dbd321167d568da17d9e562fdca6b777d88c08e03107401fbadc7cdebf243654bcde9825259117e36392f
diff --git a/dev-python/utidylib/utidylib-0.8.ebuild b/dev-python/utidylib/utidylib-0.8.ebuild
new file mode 100644
index 000000000000..095b63b34c3a
--- /dev/null
+++ b/dev-python/utidylib/utidylib-0.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="TidyLib Python wrapper"
+HOMEPAGE="
+ https://cihar.com/software/utidylib/
+ https://github.com/nijel/utidylib/
+ https://pypi.org/project/uTidylib/
+"
+SRC_URI="
+ https://github.com/nijel/utidylib/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=app-text/htmltidy-5.0.0
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+EPYTEST_DESELECT=(
+ # https://github.com/nijel/utidylib/issues/9
+ tidy/test_tidy.py::TidyTestCase::test_missing_load
+)