summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-23 20:39:03 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-23 22:28:19 +0300
commit20fce314a38c6d72765b30f6edc0bb800f5e8104 (patch)
treecc0393af1bb4e60fd4b42c12ca1cfa4a18b8b4f3 /dev-python/uvicorn
parentgnome-extra/gnome-documents: Remove (diff)
downloadgentoo-20fce314a38c6d72765b30f6edc0bb800f5e8104.tar.gz
gentoo-20fce314a38c6d72765b30f6edc0bb800f5e8104.tar.bz2
gentoo-20fce314a38c6d72765b30f6edc0bb800f5e8104.zip
dev-python/uvicorn: add 0.18.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/uvicorn')
-rw-r--r--dev-python/uvicorn/Manifest1
-rw-r--r--dev-python/uvicorn/uvicorn-0.18.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/uvicorn/Manifest b/dev-python/uvicorn/Manifest
index db661330a4fa..6d256308a808 100644
--- a/dev-python/uvicorn/Manifest
+++ b/dev-python/uvicorn/Manifest
@@ -1 +1,2 @@
DIST uvicorn-0.17.6.tar.gz 708048 BLAKE2B 83b06907c8109b38e13930d8b73584682fa4e34fe7e51fe14b6ca1ddc7ef8122d950a09e31cb364a02f5f12eead5d0522b41cbf428509c6900604d4e2776dfb2 SHA512 d5c5223759d59648f279e22f7e6af728fe8117ed75488d125c1db3e5e9d385a50d574cff72ac46db4eb0a78d0e4f690096cfe78c774674dfba61860e55b7494e
+DIST uvicorn-0.18.1.gh.tar.gz 712588 BLAKE2B f99c173015d3efdd6f7d6257384045542cbf95ab65fdd84f47ee5df4677865d0b4d6de5f23db0bc2713cb286242a029b056c4076268b14d238a3e9f57c02fc42 SHA512 d8650ace78d19c44d03de8413bf06b2dd3208c7e47c4d9e17ecbed99eef938ec08eb249b204713139b985ae4b117c7da64836c25bf8d20610363bedcf1ebf990
diff --git a/dev-python/uvicorn/uvicorn-0.18.1.ebuild b/dev-python/uvicorn/uvicorn-0.18.1.ebuild
new file mode 100644
index 000000000000..3c0926979406
--- /dev/null
+++ b/dev-python/uvicorn/uvicorn-0.18.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Lightning-fast ASGI server implementation"
+HOMEPAGE="https://www.uvicorn.org/"
+SRC_URI="https://github.com/encode/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/asgiref-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/h11-0.8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ >=dev-python/websockets-10.0[${PYTHON_USEDEP}]
+ dev-python/wsproto[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # too long path for unix socket
+ tests/test_config.py::test_bind_unix_socket_works_with_reload_or_workers
+ # need unpackaged httptools
+ "tests/middleware/test_logging.py::test_trace_logging_on_http_protocol[httptools]"
+ tests/protocols/test_http.py::test_fragmentation
+)
+
+EPYTEST_IGNORE=(
+ # needs watchfiles, which in turn needs maturin, which needs rust
+ tests/supervisors/test_reload.py
+)
+
+pkg_postinst() {
+ optfeature "auto reload on file changes" dev-python/watchfiles
+}