summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-16 19:45:30 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-16 20:57:00 +0200
commitda455f72ea2399dd5bebea2c3f3faec0173a0ff4 (patch)
tree0aa835346cff48e3cecf6d0c45130fe8f5be72c5 /dev-python/uvicorn
parentkernel-build.eclass: Do not pass INSTALL_PATH in src_test (diff)
downloadgentoo-da455f72ea2399dd5bebea2c3f3faec0173a0ff4.tar.gz
gentoo-da455f72ea2399dd5bebea2c3f3faec0173a0ff4.tar.bz2
gentoo-da455f72ea2399dd5bebea2c3f3faec0173a0ff4.zip
dev-python/uvicorn: Skip tests requiring python-dotenv in 0.14.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/uvicorn')
-rw-r--r--dev-python/uvicorn/uvicorn-0.14.0.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/dev-python/uvicorn/uvicorn-0.14.0.ebuild b/dev-python/uvicorn/uvicorn-0.14.0.ebuild
index f6347568597c..3b12bff47fdf 100644
--- a/dev-python/uvicorn/uvicorn-0.14.0.ebuild
+++ b/dev-python/uvicorn/uvicorn-0.14.0.ebuild
@@ -42,3 +42,12 @@ python_prepare_all() {
-i tests/supervisors/test_reload.py
distutils-r1_python_prepare_all
}
+
+python_test() {
+ local deselect=(
+ # requires python-dotenv that's not keyworded everywhere yet
+ # see 0.14.0-r1
+ tests/test_config.py::test_env_file
+ )
+ epytest ${deselect[@]/#/--deselect }
+}